Bug 1313307 - VPN connection fails
VPN connection fails
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-01 06:21 EST by javiertury
Modified: 2016-12-20 14:09 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-20 14:09:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description javiertury 2016-03-01 06:21:15 EST
Description of problem:

Network Manager's OpenVPN and PPTP plugins don't work unless the service is started as root manually from a terminal.

Using the GUI to connect to a VPN silently fails inmediatly. This is what gets logged to jorunalctl:
Mar 01 12:14:53 localhost.localdomain dbus[3393]: [system] Activating via systemd: service name='org.freedesktop.ModemManager1' unit='dbus-org.freedesktop.ModemManager1.service'
Mar 01 12:14:53 localhost.localdomain dbus[3393]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.ModemManager1.service': Unit dbus-org.freedesktop.ModemManager1.service failed to load: No such file or directory.
Mar 01 12:14:53 localhost.localdomain gnome-control-center.desktop[16175]: (gnome-control-center:16175): network-cc-panel-WARNING **: Error connecting to ModemManager: Error calling StartServiceByName for org.freedesktop.ModemManager1: GDBus.Error:org.freedesktop.systemd1.LoadFailed: Unit dbus-org.freedesktop.ModemManager1.service failed to load: No such file or directory.
Mar 01 12:14:56 localhost.localdomain NetworkManager[3522]: <info>  Starting VPN service 'openvpn'...
Mar 01 12:14:56 localhost.localdomain NetworkManager[3522]: <info>  VPN service 'openvpn' started (org.freedesktop.NetworkManager.openvpn), PID 16207
Mar 01 12:14:56 localhost.localdomain NetworkManager[3522]: <info>  VPN service 'openvpn' appeared; activating connections
Mar 01 12:14:57 localhost.localdomain NetworkManager[3522]: <info>  VPN plugin state changed: starting (3)
Mar 01 12:14:57 localhost.localdomain NetworkManager[3522]: <info>  VPN service 'openvpn' disappeared
Mar 01 12:14:57 localhost.localdomain NetworkManager[3522]: <warn>  error disconnecting VPN: The name org.freedesktop.NetworkManager.openvpn was not provided by any .service files

From "systemctl -a" I can see this line, which may have something to do with this problem:
org.freedesktop.NetworkManager.busname not-found inactive dead org.freedesktop.NetworkMan

However if I manually start this daemon and leave the termianl open,
sudo /usr/libexec/nm-openvpn-service --debug

Then it connects without problem from Network Manager's GUI. For PPTP connections it is the same except that the following command has to be entered:
sudo /usr/libexec/nm-pptp-service --debug


Version-Release number of selected component (if applicable):
NetworkManager.x86_64                  1:1.0.10-2.fc23
NetworkManager-openvpn.x86_64          1:1.0.8-2.fc23
NetworkManager-openvpn-gnome.x86_64    1:1.0.8-2.fc23
NetworkManager-pptp.x86_64             1:1.1.0-2.20150428git695d4f2.fc23
NetworkManager-pptp-gnome.x86_64       1:1.1.0-2.20150428git695d4f2.fc23
Comment 1 javiertury 2016-03-01 08:24:21 EST
This is the output when the services are started as a non-privileged user:
$/usr/libexec/nm-openvpn-service

(nm-openvpn-service:17232): libnm-glib-WARNING **: Failed to initialize VPN plugin: Connection ":1.1597" is not allowed to own the service "org.freedesktop.NetworkManager.openvpn" due to security policies in the configuration file

(nm-openvpn-service:17232): GLib-GObject-CRITICAL **: object NMOpenvpnPlugin 0x5585fb6fe0f0 finalized while still in-construction

(nm-openvpn-service:17232): GLib-GObject-CRITICAL **: Custom constructor for class NMOpenvpnPlugin returned NULL (which is invalid). Please use GInitable instead.



The problem seems to be that non-root users don't have permission to choose VPN. However the GUI is not greyed out nor does it ask for sudo/root password.
Comment 2 LayerTwo 2016-03-15 15:07:57 EDT
I also have a similar issue. 

My OpenVPN connection just timesout. Selinux complains a lot about it. 

For testing, i have created a VM with Mint 17 and it worked first time with my config file.

Tried L2TP and PPTP and also no joy
Comment 3 Fedora End Of Life 2016-11-24 10:51:54 EST
This message is a reminder that Fedora 23 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 23. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '23'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 23 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 4 Fedora End Of Life 2016-12-20 14:09:16 EST
Fedora 23 changed to end-of-life (EOL) status on 2016-12-20. Fedora 23 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.