Bug 1313337 - Test case failure: /CoreOS/edac-utils/Sanity/edac-ctl-mainboard
Test case failure: /CoreOS/edac-utils/Sanity/edac-ctl-mainboard
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: edac-utils (Show other bugs)
7.2
Unspecified Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Aristeu Rozanski
Andrej Manduch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-01 07:28 EST by Karel Volný
Modified: 2016-03-01 09:36 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-01 09:17:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2016-03-01 07:28:55 EST
Filed from caserun https://tcms.engineering.redhat.com/run/274722/#caserun_11896648

Version-Release number of selected component (if applicable):
RHEL-7.2-20151030.0
edac-utils-0.16-14.el7.x86_64

Steps to Reproduce: 
run the test /CoreOS/edac-utils/Sanity/edac-ctl-mainboard


Actual results: 
:: [  BEGIN   ] :: root can run edac-ctl --mainboard :: actually running 'edac-ctl --mainboard'
edac-ctl: mainboard:  
:: [   PASS   ] :: root can run edac-ctl --mainboard (Expected 0, got 0)
:: [  BEGIN   ] :: non-root user can run edac-ctl --mainboard :: actually running 'su -c 'edac-ctl --mainboard' edacan'
Must be root to run dmidecode
:: [   FAIL   ] :: non-root user can run edac-ctl --mainboard (Expected 0, got 2)


Expected results:
:: [  BEGIN   ] :: root can run edac-ctl --mainboard :: actually running 'edac-ctl --mainboard'
edac-ctl: mainboard:  
:: [   PASS   ] :: root can run edac-ctl --mainboard (Expected 0, got 0)
:: [  BEGIN   ] :: non-root user can run edac-ctl --mainboard :: actually running 'su -c 'edac-ctl --mainboard' edacan'
edac-ctl: mainboard: 
:: [   PASS   ] :: non-root user can run edac-ctl --mainboard (Expected 0, got 0)


Additional info:
it seems that this test never passed on RHEL7 (however, we haven't run it since RHEL-7.0-20140127.0 until now when I got it assigned and it failed on latest RHEL 7.2 too)
Comment 2 Aristeu Rozanski 2016-03-01 09:08:51 EST
See https://bugzilla.redhat.com/show_bug.cgi?id=1313336#c2
Comment 3 Aristeu Rozanski 2016-03-01 09:17:42 EST
See https://bugzilla.redhat.com/show_bug.cgi?id=1313336#c3

Note You need to log in before you can comment on or make changes to this bug.