Bug 1313368 - keystone wsgi default worker number threads vs. processes
keystone wsgi default worker number threads vs. processes
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: Emilien Macchi
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-01 08:30 EST by Attila Fazekas
Modified: 2016-04-18 02:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-01 12:40:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Attila Fazekas 2016-03-01 08:30:32 EST
Description of problem:

Puppet keystone default the number of python threads to the number of processors,
instead of setting processes to nr_cpu and leave the threads to 1.


Version-Release number of selected component (if applicable):
openstack-puppet-modules-7.0.6-2.el7ost.noarch
puppet-3.6.2-2.el7.noarch
openstack-packstack-puppet-7.0.0-0.12.dev1699.g8f54936.el7ost.noarch


Actual results:
$ cat /etc/httpd/conf.d/10-keystone_wsgi_admin.conf |grep thread
WSGIDaemonProcess keystone_admin display-name=keystone-admin group=keystone processes=1 threads=4 user=keystone

Expected results:
WSGIDaemonProcess keystone_admin display-name=keystone-admin group=keystone processes=4 threads=1 user=keystone

Additional info:
cat /proc/cpuinfo |grep process | wc -l
4

It will lead to little more memory usage,
but you will be able utilize the cpu.

If the DB in LAN range, you should not try to increase the number of threads by default.
Comment 2 Emilien Macchi 2016-03-01 12:40:20 EST
Attila, thanks for your bug report.
Since we're using Launchpad to track bugs in upstream projects, it would be very nice to report this bug in https://bugs.launchpad.net/puppet-keystone

Also, if you think that's a bug in OSP Director, you might want to create a bug for TripleO Heat Templates to change the values.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.