This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1313414 - [DOCS] use 'atomic.io' as the base for the etcd config key when configuring flannel
[DOCS] use 'atomic.io' as the base for the etcd config key when configuring f...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: doc-RHEL-Atomic (Show other bugs)
7.2
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Chris Negus
Vikram Goyal
Vikram Goyal
: Documentation, Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-01 10:05 EST by Micah Abbott
Modified: 2017-03-14 23:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-14 23:36:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Micah Abbott 2016-03-01 10:05:25 EST
Description of problem:

In the documentation for setting up a Kubernetes cluster [1], the configuration of flannel instructs the user to use an etcd config key of '/coreos.com/network'.  However, the flannel package is shipped with a default value of '/atomic.io/network'.  I think it would be preferable to use this default value in place of the 'coreos.com' value.

[1] https://access.redhat.com/documentation/en/red-hat-enterprise-linux-atomic-host/version-7/getting-started-with-containers/#creating_a_kubernetes_cluster_to_run_docker_formatted_container_images


In section 3.5 "Setting up Kubernetes on the Master", the following commands/instructions should be changed:


# etcdctl set coreos.com/network/config < flannel-config.json

...should be changed to...

# etcdctl set /atomic.io/network/config < flannel-config.json


# etcdctl get coreos.com/network/config

...should be changed to...

# etcdctl get /atomic.io/network/config


The config file '/etc/sysconfig/flanneld' should have the following content:

FLANNEL_ETCD="http://master.example.com:2379"
FLANNEL_ETCD_KEY="/atomic.io/network"
Comment 2 Micah Abbott 2016-03-01 10:31:35 EST
The same change will need to be made in section 3.6 "Setting up Kubernetes on the Nodes", Step 5.
Comment 4 Chris Negus 2016-09-19 14:07:18 EDT
I'll fix this for RHEL/Atomic 7.3.
Comment 5 Chris Negus 2017-03-13 16:04:46 EDT
The chapter identified here was corrected to use "atomic.io" as the base for the etcd configuration information. However, the chapter has since been dropped, because we no long support manual configuration of multi-node Kubernetes. I checked the other documentation in this area and we do properly identify "atomic.io" as the configuration base in our flannel documentation[1]. I think we can close this bug.

[1] https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux_atomic_host/7/html-single/managing_containers/#configuring_flannel
Comment 6 Vikram Goyal 2017-03-14 23:36:49 EDT
Thanks Chris. I will close this bug as CURRENTRELEASE based on your previous comment.

https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux_atomic_host/7/html-single/managing_containers/#configuring_flannel

If there are any other issues, please open a new bug.

Note You need to log in before you can comment on or make changes to this bug.