Bug 1313519 - relax restraint client xml schema checks
relax restraint client xml schema checks
Status: CLOSED CURRENTRELEASE
Product: Restraint
Classification: Community
Component: general (Show other bugs)
0.1.23
Unspecified Unspecified
unspecified Severity unspecified
: 0.1.24
: ---
Assigned To: Bill Peck
tools-bugs
: Reopened, TestBlocker
: 1313520 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-01 13:34 EST by Bill Peck
Modified: 2016-08-05 20:06 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-05 16:20:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Peck 2016-03-01 13:34:53 EST
Description of problem:
Currently the restraint xml validates the xml to make sure the xml provides proper rpm or fetch elements.  But any extra elements will cause the validation to fail.  This happens if you export an xml from beaker which has extra elements and attributes that restraint doesn't care about.

Version-Release number of selected component (if applicable):
0.2.23-1
Comment 1 Bill Peck 2016-03-01 13:46:54 EST
*** Bug 1313520 has been marked as a duplicate of this bug. ***
Comment 2 Bill Peck 2016-03-01 13:47:56 EST
http://gerrit.beaker-project.org/#/c/4705/
Comment 3 Dan Callaghan 2016-04-17 22:02:04 EDT
Looks like this was included with restraint 0.1.24.
Comment 4 Xiyang Dong 2016-07-21 13:52:00 EDT
I am still seeing this issue on restraint-0.1.24-1.el7_2.x86_64:

restraint xml:
https://platform-stg-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/view/ipa/view/rhel-7.3/view/2.%20Tests/job/ipa-rhel-7.3-candidate-runtest-upstream_automember/1/artifact/beaker-job-rhel-7.3-Server-x86_64.xml

runtest output:
15:32:08 INFO: Restraint command: /usr/bin/restraint -v -v --host 1=qe-blade-14.idmqe.lab.eng.bos.redhat.com:8081 --job=beaker-job-rhel-7.3-Server-x86_64.xml
15:32:09 beaker-job-rhel-7.3-Server-x86_64.xml:5: element repos: Relax-NG validity error : Did not expect element repos there
15:32:09 beaker-job-rhel-7.3-Server-x86_64.xml:5: element repos: Relax-NG validity error : Element recipe has extra content: repos
15:32:09 Document failed validation.

It's blocking us please investigate.
Comment 5 Xiyang Dong 2016-08-05 16:20:50 EDT
(In reply to Xiyang Dong from comment #4)
> I am still seeing this issue on restraint-0.1.24-1.el7_2.x86_64:
> 
> restraint xml:
> https://platform-stg-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/view/ipa/view/
> rhel-7.3/view/2.%20Tests/job/ipa-rhel-7.3-candidate-runtest-
> upstream_automember/1/artifact/beaker-job-rhel-7.3-Server-x86_64.xml
> 
> runtest output:
> 15:32:08 INFO: Restraint command: /usr/bin/restraint -v -v --host
> 1=qe-blade-14.idmqe.lab.eng.bos.redhat.com:8081
> --job=beaker-job-rhel-7.3-Server-x86_64.xml
> 15:32:09 beaker-job-rhel-7.3-Server-x86_64.xml:5: element repos: Relax-NG
> validity error : Did not expect element repos there
> 15:32:09 beaker-job-rhel-7.3-Server-x86_64.xml:5: element repos: Relax-NG
> validity error : Element recipe has extra content: repos
> 15:32:09 Document failed validation.
> 
> It's blocking us please investigate.

The above issue was actually caused by missing fetch url link of the first task in restraint xml, no validation fail after adding url.
So not a regression.Mark this as closed.

Note You need to log in before you can comment on or make changes to this bug.