Bug 1313520 - relax restraint client xml schema checks
Summary: relax restraint client xml schema checks
Status: CLOSED DUPLICATE of bug 1313519
Alias: None
Product: Restraint
Classification: Community
Component: general   
(Show other bugs)
Version: 0.1.23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: beaker-dev-list
QA Contact: tools-bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-01 18:35 UTC by Bill Peck
Modified: 2016-04-21 00:18 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-01 18:46:54 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Peck 2016-03-01 18:35:26 UTC
Description of problem:
Currently the restraint xml validates the xml to make sure the xml provides proper rpm or fetch elements.  But any extra elements will cause the validation to fail.  This happens if you export an xml from beaker which has extra elements and attributes that restraint doesn't care about.

Version-Release number of selected component (if applicable):
0.2.23-1

Comment 1 Bill Peck 2016-03-01 18:46:54 UTC

*** This bug has been marked as a duplicate of bug 1313519 ***


Note You need to log in before you can comment on or make changes to this bug.