Bug 1313543 - ospd 7 poodle failing 2 tempest.scenario.test_volume_boot_pattern subtests
ospd 7 poodle failing 2 tempest.scenario.test_volume_boot_pattern subtests
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 10.0 (Newton)
Assigned To: Angus Thomas
Arik Chernetsky
: Automation, AutomationBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-01 15:35 EST by Steve Linabery
Modified: 2016-11-14 16:01 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-13 18:00:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Linabery 2016-03-01 15:35:08 EST
Description of problem:
tempest.scenario.test_volume_boot_pattern.TestVolumeBootPatternV2.test_volume_boot_pattern fails with stacktrace:

traceback-1: {{{
Traceback (most recent call last):
  File "/home/stack/tempest/tempest/services/compute/json/servers_client.py", line 195, in wait_for_server_termination
    raise exceptions.BuildErrorException(server_id=server_id)
BuildErrorException: Server e0a8a64f-1d00-4e90-b9bf-18d3c2d67eec failed to build and is in ERROR status
}}}

traceback-2: {{{
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/tempest_lib/common/rest_client.py", line 771, in wait_for_resource_deletion
    raise exceptions.TimeoutException(message)
TimeoutException: Request timed out
Details: (TestVolumeBootPatternV2:_run_cleanups) Failed to delete volume 182c463c-0f3a-4498-b404-0faf352ea3ee within the required time (300 s).
}}}

Traceback (most recent call last):
  File "/home/stack/tempest/tempest/test.py", line 126, in wrapper
    return f(self, *func_args, **func_kwargs)
  File "/home/stack/tempest/tempest/scenario/test_volume_boot_pattern.py", line 142, in test_volume_boot_pattern
    keypair)
  File "/home/stack/tempest/tempest/scenario/test_volume_boot_pattern.py", line 190, in _boot_instance_from_volume
    return self.create_server(image='', create_kwargs=create_kwargs)
  File "/home/stack/tempest/tempest/scenario/manager.py", line 181, in create_server
    status='ACTIVE')
  File "/home/stack/tempest/tempest/services/compute/json/servers_client.py", line 182, in wait_for_server_status
    ready_wait=ready_wait)
  File "/home/stack/tempest/tempest/common/waiters.py", line 74, in wait_for_server_status
    server_id=server_id)
BuildErrorException: Server e0a8a64f-1d00-4e90-b9bf-18d3c2d67eec failed to build and is in ERROR status
Details: {u'message': u'Build of instance e0a8a64f-1d00-4e90-b9bf-18d3c2d67eec aborted: Failure prepping block device.', u'code': 500, u'created': u'2016-03-01T01:28:40Z'}
Comment 2 Steve Linabery 2016-03-01 15:37:04 EST
tempest.scenario.test_volume_boot_pattern.TestVolumeBootPattern.test_volume_boot_pattern fails with a similar stacktrace:
traceback-1: {{{
Traceback (most recent call last):
  File "/home/stack/tempest/tempest/services/compute/json/servers_client.py", line 195, in wait_for_server_termination
    raise exceptions.BuildErrorException(server_id=server_id)
BuildErrorException: Server dbec5fde-7d43-412b-91aa-9f654170f75f failed to build and is in ERROR status
}}}

traceback-2: {{{
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/tempest_lib/common/rest_client.py", line 771, in wait_for_resource_deletion
    raise exceptions.TimeoutException(message)
TimeoutException: Request timed out
Details: (TestVolumeBootPattern:_run_cleanups) Failed to delete volume be167578-2457-437c-8165-b9c7c0ed79e7 within the required time (300 s).
}}}

Traceback (most recent call last):
  File "/home/stack/tempest/tempest/test.py", line 126, in wrapper
    return f(self, *func_args, **func_kwargs)
  File "/home/stack/tempest/tempest/scenario/test_volume_boot_pattern.py", line 142, in test_volume_boot_pattern
    keypair)
  File "/home/stack/tempest/tempest/scenario/test_volume_boot_pattern.py", line 66, in _boot_instance_from_volume
    return self.create_server(image='', create_kwargs=create_kwargs)
  File "/home/stack/tempest/tempest/scenario/manager.py", line 181, in create_server
    status='ACTIVE')
  File "/home/stack/tempest/tempest/services/compute/json/servers_client.py", line 182, in wait_for_server_status
    ready_wait=ready_wait)
  File "/home/stack/tempest/tempest/common/waiters.py", line 74, in wait_for_server_status
    server_id=server_id)
BuildErrorException: Server dbec5fde-7d43-412b-91aa-9f654170f75f failed to build and is in ERROR status
Details: {u'message': u'Build of instance dbec5fde-7d43-412b-91aa-9f654170f75f aborted: Failure prepping block device.', u'code': 500, u'created': u'2016-03-01T01:29:20Z'}
Comment 4 Mike Burns 2016-04-07 17:11:06 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 6 Jaromir Coufal 2016-10-11 09:33:28 EDT
Looks like Storage or Tempest issue. Also might be related to https://bugzilla.redhat.com/show_bug.cgi?id=1311763

Note You need to log in before you can comment on or make changes to this bug.