Bug 1313652 - Building book with brands fails if used --common_content
Building book with brands fails if used --common_content
Status: NEW
Product: Publican
Classification: Community
Component: publican (Show other bugs)
future
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Fearn
Ruediger Landmann
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-02 01:58 EST by Elena Mishina
Modified: 2016-05-26 09:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elena Mishina 2016-03-02 01:58:01 EST
Description of problem:
I am trying to change the brand of my book from 'common' to 'my-brand'. I don't want to use install-brand (it requires root privileges). I'm trying to use --common_content=s override path to Common_Content directory. But build fails.


Version-Release number of selected component (if applicable):
publican 4.3.2


How reproducible:


Steps to Reproduce:
1. Create a book:
publican create --type Book --lang ru-RU --name Sample --brand my-brand
2. copy folder Common_Content/my-brand into ru-RU
3. Build book:
cd Sample
publican build --formats html-single --langs ru-RU --common_content ru-RU/Common_Content

Actual results:
Setting up ru-RU
Can not copy files ru-RU/Common_Content/common/en-US/* to tmp/ru-RU/xml/Common_Content due to error:  at /usr/share/perl5/Publican/Builder/DocBook4.pm line 381.



Expected results:
Success build

Additional info:
for publican 3.0 it's worked well.
If I install my-brand for publican 4.3.2 it's worked well.

Note You need to log in before you can comment on or make changes to this bug.