Bug 1313771 - Editing composite content view shows incorrect repositories
Editing composite content view shows incorrect repositories
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Views (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-02 05:25 EST by Brad Buckingham
Modified: 2016-08-25 14:01 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-25 14:01:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad Buckingham 2016-03-02 05:25:33 EST
"ghost" repository in content view
   1. created 3 CVs (note composite1 and 2 both have same repo) and publish
    Name,Label,Organization,Composite,Repositories or Composites,Lifecycle Environments
    component1,component1,Mega Corporation,No,Red Hat Satellite Tools 6.1 for RHEL 7 Server RPMs x86_64,"Library,Baseline"
    component2,component2,Mega Corporation,No,Red Hat Satellite Tools 6.1 for RHEL 7 Server RPMs x86_64,"Library,Baseline"
    composite,composite,Mega Corporation,Yes,"component1,component2","Library,Baseline"
   2. composite fails to add repos since both have same (422 unprocessable)
   3. edit composite2 and replace 7Server w/ 6Server, publish, promote
   4. try to edit composite by adding composite2-v2.0
   Results: 2 repos displayed for composite2 but only one repo in the add/remove page
   http://www.awesomescreenshot.com/image/1041286/a4ce7a08970bde8c3e5dd9ab033e0382
   http://www.awesomescreenshot.com/image/1041287/c8ac6105f6f9231d7466513a7bf161dc
   http://www.awesomescreenshot.com/image/1041295/f320f768a6c9791a4a581717e307c700
Comment 1 Bryan Kearney 2016-07-26 15:02:58 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 4 Brad Buckingham 2016-08-25 14:01:38 EDT
Unable to reproduce this on Satellite 6.2 GA; therefore, closing.

Note You need to log in before you can comment on or make changes to this bug.