Bug 1313802 - Navigating products page throws error: [$injector:unpr] Unknown provider: eProvider <- e <- bstFeatureFlagDirective in firebug
Navigating products page throws error: [$injector:unpr] Unknown provider: eP...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Uncategorized (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium (vote)
: GA
: --
Assigned To: Walden Raines
Sachin Ghai
http://projects.theforeman.org/issues...
: Triaged
: 1328007 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-02 06:27 EST by Sachin Ghai
Modified: 2016-07-27 07:04 EDT (History)
1 user (show)

See Also:
Fixed In Version: rubygem-bastion-3.2.0.3-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 07:04:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error in Firebug console. (106.93 KB, image/png)
2016-03-02 06:27 EST, Sachin Ghai
no flags Details
no error in firebug while navigating products page (70.85 KB, image/png)
2016-05-06 09:08 EDT, Sachin Ghai
no flags Details
no error in firebug while unregistering host (116.17 KB, image/png)
2016-05-06 09:08 EDT, Sachin Ghai
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 14165 None None None 2016-04-22 12:37 EDT

  None (edit)
Description Sachin Ghai 2016-03-02 06:27:46 EST
Created attachment 1132257 [details]
Error in Firebug console.

Description of problem:
On accessing products page, Firebug filled with following error:

Error: [$injector:unpr] Unknown provider: eProvider <- e <- bstFeatureFlagDirective
http://errors.angularjs.org/1.2.9/$injector/unpr?p0=eProvider%20%3C-%20e%20%3C-%20bstFeatureFlagDirective
r/<@https://qeblade36.rhq.lab.eng.bos.redhat.com/assets/bastion/bastion-da63d18ea32fb7ba02e57c8c5bdc22689a2bee4cbf23b20f7cd975577b8bee6f.js:1:14773
Ot/$.$injector<@https://qeblade36.rhq.lab.eng.bos.redhat.com/assets/bastion/bastion-da63d18ea32fb7ba02e57c8c5bdc22689a2bee4cbf23b20f7cd975577b8bee6f.js:1:30308
n@https://qeblade36.rhq.lab.eng.bos.redhat.com/assets/bastion/bastion-da63d18ea32fb7ba02e57c8c5bdc22689a2bee4cbf23b20f7cd975577b8bee6f.js:1:29573
Ot/x.$injector<@https://qeblade36.rhq.lab.eng.bos.redhat.com/assets/bastion/bastion-da63d18ea32fb7ba02e57c8c5bdc22689a2bee4cbf23b20f7cd975577b8bee6f.js:1:30401

Version-Release number of selected component (if applicable):
Sat 6.2 snap1

How reproducible:
always

Steps to Reproduce:
1. goto contents -> products page
2.
3.

Actual results:
Error in Firebug console. Looks like something related to bastion.

Expected results:
Firebug shouldn't throw any error.

Additional info:
Comment 2 Walden Raines 2016-03-11 14:57:05 EST
Created redmine issue http://projects.theforeman.org/issues/14165 from this bug
Comment 3 Walden Raines 2016-03-11 15:01:43 EST
PR - https://github.com/Katello/bastion/pull/104
Comment 4 Bryan Kearney 2016-03-11 16:05:47 EST
Upstream bug component is Uncategorized
Comment 5 Bryan Kearney 2016-03-11 16:05:50 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/14165 has been closed
-------------
Walden Raines
Applied in changeset commit:bastion|c05efd22933d5e3ff60e3ef7dee15024b04c6c96.
Comment 6 Brad Buckingham 2016-04-18 11:55:17 EDT
*** Bug 1328007 has been marked as a duplicate of this bug. ***
Comment 7 Brad Buckingham 2016-04-18 11:56:02 EDT
When verifying this bug, please also confirm the behavior raised by bug 1328007.
Comment 8 Sachin Ghai 2016-05-06 09:07:10 EDT
Verified with sat6.2 GA snap10

I don't see any error in firebug on navigating Products page. Also checked with chrome developer tools.

As per comment7, I also checked the firebug for same error while unregistering the host from webUI. In any case, the reported issue is no longer reproducible. Thanks
Comment 9 Sachin Ghai 2016-05-06 09:08 EDT
Created attachment 1154617 [details]
no error in firebug while navigating  products page
Comment 10 Sachin Ghai 2016-05-06 09:08 EDT
Created attachment 1154618 [details]
no error in firebug while unregistering host
Comment 11 Bryan Kearney 2016-07-27 07:04:12 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.