Bug 1313946 - Cannot download repodata/repomd.xml: All mirrors were tried
Cannot download repodata/repomd.xml: All mirrors were tried
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-02 11:37 EST by Thomas Schweikle
Modified: 2016-03-14 08:29 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-14 08:29:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Schweikle 2016-03-02 11:37:12 EST
Description of problem:
dnf doesn't find repomd.xml on any server. Looks like it is searching at the wrong place ...

Version-Release number of selected component (if applicable):
dnf-1.1.6-2.fc24.noarch

How reproducible:
Allways

Steps to Reproduce:
1. Install, Upgrade to latest
2. dnf fails to find repomd.xml
3.

Actual results:
dnf fails to find repomd.xml

Expected results:
dnf finding repomd.xml

Additional info:
looks like dnf searches for something else than repomd.xml.

Same Error is found with rawhide.
Comment 1 Thomas Schweikle 2016-03-02 12:00:58 EST
The error is quite simple: fedora-repos-24-0.4.noarch sets up fedora 24 repo at: baseurl=http://download.fedoraproject.org/pub/fedora/linux/releases/$releasever/Everything/$basearch/os/

while real data is at: http://download.fedoraproject.org/pub/fedora/linux/development/$releasever/Everything/$basearch/os/

if you work with metalink= (the default) the servers behind give back wrong paths for ALL servers. In tune none of repomd.xml can be found. Please fix it on the server side!
Comment 2 Thomas Schweikle 2016-03-02 12:02:03 EST
The same is done for rawhide.
Comment 3 Honza Silhan 2016-03-14 08:29:33 EDT
Thomas, file a ticket in Fedora infrastructure tracker system, please. I am closing this as I can't redirect it.

Note You need to log in before you can comment on or make changes to this bug.