Bug 1313976 - hammer lifecycle-environment create requires 'prior-id' if 'prior' parameter is set
hammer lifecycle-environment create requires 'prior-id' if 'prior' parameter ...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium (vote)
: Beta
: --
Assigned To: David Davis
Og Maciel
http://projects.theforeman.org/issues...
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-02 13:10 EST by Roman Plevka
Modified: 2016-07-27 07:24 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 07:24:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13875 None None None 2016-04-22 12:52 EDT

  None (edit)
Description Roman Plevka 2016-03-02 13:10:30 EST
Description of problem:
it's not possible to create a lifecycle environment with specifying only a prior environment by its name (using --prior paramter).
Hammer requires --prior-id to be set, rendering --prior parameter quite useless

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. hammer --output=csv lifecycle-environment create --prior="Library" --organization-id="1" --name="foo"


Actual results:
Missing arguments for 'prior_id'
Could not create environment:
Missing arguments for 'prior_id'


Expected results:
Lifecycle environment is created.

Additional info:
tested with snap2
Comment 7 Og Maciel 2016-03-18 16:51:41 EDT
Closed this by mistake.
Comment 8 Og Maciel 2016-03-18 16:55:26 EDT
[root@ibm-x3250m4-01 ~]# hammer -v -u admin -p changeme lifecycle-environment create --prior="Library" --organization-id="1" --name="DEV"
Environment created
[root@ibm-x3250m4-01 ~]# hammer -v -u admin -p changeme lifecycle-environment list --organization-id="1"
---|---------|--------
ID | NAME    | PRIOR
---|---------|--------
1  | Library |
2  | DEV     | Library
---|---------|--------
[root@ibm-x3250m4-01 ~]# hammer -v -u admin -p changeme lifecycle-environment create --prior="DEV" --organization-id="1" --name="QE"
Environment created
[root@ibm-x3250m4-01 ~]# hammer -v -u admin -p changeme lifecycle-environment list --organization-id="1"---|---------|--------
ID | NAME    | PRIOR
---|---------|--------
3  | QE      | DEV
1  | Library |
2  | DEV     | Library
---|---------|--------
[root@ibm-x3250m4-01 ~]# hammer -v -u admin -p changeme lifecycle-environment create --prior="Library" --organization-id="1" --name="GA"
Environment created
[root@ibm-x3250m4-01 ~]# hammer -v -u admin -p changeme lifecycle-environment list --organization-id="1"---|---------|--------
ID | NAME    | PRIOR
---|---------|--------
3  | QE      | DEV
1  | Library |
4  | GA      | Library
2  | DEV     | Library
---|---------|--------
Comment 9 Og Maciel 2016-03-18 16:56:02 EDT
Verified on Satellite 6.2.0 SNAP 4.0 Build.
Comment 12 Bryan Kearney 2016-07-27 07:24:34 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.