Bug 131400 - Transparency setting on a terminal window not showing everything
Summary: Transparency setting on a terminal window not showing everything
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-31 23:44 UTC by Paul F. Johnson
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-05 23:29:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul F. Johnson 2004-08-31 23:44:25 UTC
Description of problem:
If I set the transparency of the terminal window to (say) 45%, I can
see the background image, but nothing else which is on the desktop
(such as icons or other open windows)

Version-Release number of selected component (if applicable):
2.7.3-1

How reproducible:
Always

Steps to Reproduce:
1. Make the terminal window 45% transparent
2. Move over any open windows
3.
  
Actual results:
The open windows (such as if I open a terminal window over this page
while editting it), are not viewable, but the background behind
everything else is.

Expected results:
You should only be able to see what is directly behind the open
terminal window. Looks like the window stacking is not correct

Additional info:

Comment 1 Ray Strode [halfline] 2004-11-05 23:29:45 UTC
Unfortunately, X currently doesn't provide a mechanism for doing what
you want.  Gnome-terminal merely provides a pseudo-transparency (just
shows the desktop background).  In the future when X Composite support
becomes mature this should be possible, but that is going to be a while.


Note You need to log in before you can comment on or make changes to this bug.