Bug 131403 - S3 Unichrome graphics chipset not detected
S3 Unichrome graphics chipset not detected
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hwdata (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-31 20:03 EDT by Jason Tibbitts
Modified: 2014-03-16 22:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 12:08:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -vvxxx output (16.08 KB, text/plain)
2004-08-31 20:05 EDT, Jason Tibbitts
no flags Details

  None (edit)
Description Jason Tibbitts 2004-08-31 20:03:34 EDT
Running FC2 with latest rawhide kernel (2.6.8-1.533), Xorg
(6.7.99.903-1), hwdata (0.124-1) and s-c-display (1.0.18-2), the S3
Unichrome graphics chipset (on an Abit VA-10 motherboard) is supported
(by the Xorg "via" driver) but is not detected by s-c-display:

> s system-config-display --verbose --reconfig --noui
* ddcprobe returned bogus values:
ID:   None
Name: None
HorizSync: None
VertSync:  None

Trying with card: VESA driver (generic)
Backing up /etc/X11/xorg.conf to /etc/X11/xorg.conf.backup
Writing configuration to /etc/X11/xorg.conf
Removing old /etc/X11/X
Creating /etc/X11/X symlink

The system is connected to a KVM and DCC doesn't usually work through
it, so that's not necessarily problematic.

lspci has this to say about the chipset:

01:00.0 VGA compatible controller: VIA Technologies, Inc. VT8378 [S3
UniChrome] Integrated Video (rev 01) (prog-if 00 [VGA])
        Subsystem: ABIT Computer Corp.: Unknown device 140b
        Flags: bus master, 66Mhz, medium devsel, latency 32, IRQ 11
        Memory at d8000000 (32-bit, prefetchable)
        Memory at dc000000 (32-bit, non-prefetchable) [size=16M]
        Capabilities: [60] Power Management version 2
        Capabilities: [70] AGP version 2.0

I will attach the full lspci -vvxxx output.
Comment 1 Jason Tibbitts 2004-08-31 20:05:23 EDT
Created attachment 103322 [details]
lspci -vvxxx output
Comment 3 Paul Nasrat 2004-09-06 10:48:33 EDT
What are we picking up via ddc for the video chipset itself (as root):

/usr/sbin/kudzu -p -b ddc

/usr/sbin/kudzu -p -c video

Comment 4 Jason Tibbitts 2004-09-06 10:52:41 EDT
Here you go; I'm not at work right now so I shut down the X server and
ran these remotely:

#/usr/sbin/kudzu -p -b ddc
-
class: VIDEO
bus: DDC
detached: 0
driver: unknown
desc: ""
mem: 32768

#> s /usr/sbin/kudzu -p -c video
-
class: VIDEO
bus: PCI
detached: 0
driver: unknown
desc: "VIA Technologies|VT8378 [S3 UniChrome] Integrated Video"
vendorId: 1106
deviceId: 7205
subVendorId: 147b
subDeviceId: 140b
pciType: 1
pcidom:    0
pcibus:  1
pcidev:  0
pcifn:  0
Comment 5 Marcelo Mathias Lima 2004-09-22 23:26:05 EDT
I have exactly the same problem. I am using Fedora Core 2 and the
outpout of kudzu is identical. I want to solve it too...

thank u!!
Comment 6 Richard Birkby 2004-09-27 07:20:27 EDT
I get the following on Fedora Core 3 Test 2 using a Biostar iDeq 200V
SFF PC. The system detects a generic VESA device, just as in FC2

class: VIDEO
bus: PCI
detached: 0
driver: unknown
desc: "VIA Technologies, Inc. VT8378 [S3 UniChrome] Integrated Video"
vendorId: 1106
deviceId: 7205
subVendorId: 1106
subDeviceId: 7205
pciType: 1
pcidom:    0
pcibus:  1
pcidev:  0
pcifn:  0
Comment 7 Paul Nasrat 2004-09-30 03:26:45 EDT
Looks like it needs to be added to hwdata Cards db to me.
Comment 8 Bill Nottingham 2004-09-30 12:08:27 EDT
Added, will be in 0.136-1.

Note You need to log in before you can comment on or make changes to this bug.