Bug 13141 - PHP3 spec file doesn't support MySQL well
PHP3 spec file doesn't support MySQL well
Status: CLOSED DUPLICATE of bug 10987
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-27 21:35 EDT by Bob Ramstad
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-27 21:35:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Ramstad 2000-06-27 21:35:13 EDT
howdy.  i tried to follow various directions to get PHP3 to build with 
MySQL support and had a lot of problems.

in particular, if i uncomment the various lines in the spec file to enable 
MySQL support, i get errors from the system that there is no "mysql" 
module.

i ended up hacking and slashing my way through it by manually taking the 
%post, %postun and %files mysql sections and slapping them on the main 
section.

the other thing i had to do (of course) was add a "--with-mysql" to the 
configuration line.

certainly for PHP4 it would be nice if this could get straightened out so 
it is easy to fix things up for MySQL support.  getting Apache + PHP + 
MySQL to work together seems to be a common task and it is more difficult 
than necessary as it stands now.

here's a really nutty idea... how about providing TWO spec files, with 
different names -- one php.spec and one php-mysql.spec?  that would avoid a 
whole lot of problems and might be the most elegant solution.

-- Bob
Comment 1 Nalin Dahyabhai 2000-06-27 21:44:01 EDT
This should already be resolved in Raw Hide (ftp://ftp.redhat.com/pub/rawhide/),
because PHP 4.0 now includes a bundled version of the MySQL client, and you need
only change a --without-mysql to a --with-mysql to enable it.

*** This bug has been marked as a duplicate of 10987 ***

Note You need to log in before you can comment on or make changes to this bug.