Bug 131432 - pam_unix.so broken_shadow option not working
pam_unix.so broken_shadow option not working
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pam (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-01 08:10 EDT by Dmitry Butskoy
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-21 06:02:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
needed correction to old broken_shadow patch (441 bytes, patch)
2004-09-01 08:16 EDT, Dmitry Butskoy
no flags Details | Diff
"whole" broken_shadow patch as it should be (2.17 KB, patch)
2004-09-24 08:02 EDT, Dmitry Butskoy
no flags Details | Diff
patch for current buggy patch ("patch for patch"...) (307 bytes, patch)
2004-09-24 08:04 EDT, Dmitry Butskoy
no flags Details | Diff

  None (edit)
Description Dmitry Butskoy 2004-09-01 08:10:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040806

Description of problem:
There is some little bug in the "pam-0.77-unix-brokenshadow.patch",
which cause "broken_shadow" option to work not properly. It is easy to
fix, see attached...

Version-Release number of selected component (if applicable):
pam-0.77-15

How reproducible:
Always

Steps to Reproduce:
Just see source code to understand
    

Additional info:
Comment 1 Dmitry Butskoy 2004-09-01 08:16:04 EDT
Created attachment 103334 [details]
needed correction to old broken_shadow patch

It is very old problem.
In RedHat-7.3 "broken_shadow" option behaves like "already set",
in Fedora Core 1 -- like "never set" ...
  The reason is appropriate macro was changed from bitmask to enum value (See
the patch).
Comment 2 Dmitry Butskoy 2004-09-24 08:02:35 EDT
Created attachment 104255 [details]
"whole" broken_shadow patch as it should be
Comment 3 Dmitry Butskoy 2004-09-24 08:04:26 EDT
Created attachment 104256 [details]
patch for current buggy patch ("patch for patch"...)
Comment 4 Dmitry Butskoy 2004-09-24 08:05:41 EDT
In Fedore Core 3 test2 this bug is still not resolved...
Comment 5 Dmitry Butskoy 2004-10-11 11:09:49 EDT
Still in FC3 test3 ...
Comment 6 Tomas Mraz 2004-10-19 08:42:11 EDT
Applied. Thank you.
Comment 7 Nicolas Mailhot 2004-10-27 06:26:57 EDT
With
account     required      /lib/security/$ISA/pam_unix.so broken_shadow
in
/etc/pam.d/system-auth
the rawhide login stack works. Thanks !

(not closing since the packages are not fixed yet)

Note You need to log in before you can comment on or make changes to this bug.