Bug 1314388 - ejb3 -> Strict Max Bean Instance Pool: failed to change configuration parameters
ejb3 -> Strict Max Bean Instance Pool: failed to change configuration parame...
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 7 (Show other bugs)
JON 3.3.5
Unspecified Unspecified
medium Severity medium
: CR01
: One-off release
Assigned To: Michael Burman
Hayk Hovsepyan
: Triaged
Depends On:
Blocks: 1314853
  Show dependency treegraph
 
Reported: 2016-03-03 08:39 EST by Hayk Hovsepyan
Modified: 2016-06-06 14:58 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-06 14:58:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server.log (15.33 KB, text/plain)
2016-03-04 03:30 EST, Hayk Hovsepyan
no flags Details

  None (edit)
Description Hayk Hovsepyan 2016-03-03 08:39:27 EST
Description of problem:
It is not possible to change ejb3 subsystem's "Strict Max Bean Instance Pool" configuration property values.

Version-Release number of selected component (if applicable):
Version 3.3
Update-03
DR01 
jon-plugin-pack-eap-3.3.0.GA.zip

How reproducible:
always

Steps to Reproduce:
1. Change some of property values, for instance "Max Pool Size". Save them.
2. Reload the properties. Values will be the old ones.


Actual results:
New values are not saved.

Expected results:
Should be saved as happens for EAP6 plugin.
Comment 1 Hayk Hovsepyan 2016-03-04 03:30 EST
Created attachment 1133108 [details]
server.log

Attaching server log which happens after clicking save.
Comment 2 Hayk Hovsepyan 2016-03-04 03:32:10 EST
Alert message which shows after saving and returning to "Current" subtab of Configurations:

"Failed to retrieve member Resource configurations for [ResourceGroup[id=10032, name=ejb3 ( Strict Max Bean Instance Pool ), category=COMPATIBLE, type=Strict Max Bean Instance Pool, isDynaGroup=false, isClusterGroup=false]]"

"Current" subtab is empty here.
Comment 3 Michael Burman 2016-03-08 09:53:37 EST
The reason is that max-pool-size and derived-size can't be both used in EAP7.
Comment 4 Michael Burman 2016-03-10 08:23:48 EST
In the master:

commit f7a8a1e389cca25e8aa6b2aec6e1bb26de46e582
Author: Michael Burman <miburman@redhat.com>
Date:   Thu Mar 10 15:23:07 2016 +0200

    [BZ 1314388] Update properties of pool-configuration in EJB3 and send only max-pool-size or derive-size to the server
Comment 5 Mike McCune 2016-03-28 19:06:24 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 8 Hayk Hovsepyan 2016-04-01 08:00:19 EDT
Tested on revision: jon-plugin-pack-eap-3.3.0.GA-update-04-DR02.

Still not able to save neither "Derive Size" nor "Max Pool Size".

Steps:
Unset one of them, set the another one.
Save.
It still shows the old values.

Tried with JBoss CLI manally, it works.
Comment 9 Michael Burman 2016-04-04 08:48:26 EDT
Fixed in the master:

commit e882ea67aa642eb9821424f41dfd15abcb0d1729
Author: Michael Burman <miburman@redhat.com>
Date:   Mon Apr 4 15:47:52 2016 +0300

    [BZ 1314388] Using composite operation to do undefine for derive-size
Comment 12 Hayk Hovsepyan 2016-04-12 10:43:45 EDT
Verified on revision jon33-eap-update04 ER01
Comment 17 Hayk Hovsepyan 2016-04-29 10:27:02 EDT
Verified on revision jon33-eap-update04 CR01.

Note You need to log in before you can comment on or make changes to this bug.