Bug 131444 - logrotate for jonas is broken
logrotate for jonas is broken
Status: CLOSED ERRATA
Product: Red Hat Application Server
Classification: Retired
Component: jonas (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Permaine Cheung
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-01 11:16 EDT by Thomas Uebermeier
Modified: 2007-04-18 13:11 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-16 11:54:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Uebermeier 2004-09-01 11:16:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux 2.6.6-1.435.2.3smp) (KHTML, like Gecko)

Description of problem:
cat /etc/logrotate.d/rhdb-jonas:
"/etc/logrotate.d/rhdb-jonas" {
        copytruncate
        notifempty
        nomail
        postrotate
/etc/rc.d/init.d rhdb-jonas reload
        endscript
        daily
}

Line 5 has a missing '/' between 'init.d' and 'rhdb-jonas'


Version-Release number of selected component (if applicable):
jonas-4.1.1-1jpp_4rh

How reproducible:
Always

Steps to Reproduce:
N/A

Actual Results:  logrotate does not reload rhdb-jonas after rotating the logs

Expected Results:  rhdb-jonas should be reloaded to recreate the logfile

Additional info:

--- rhdb-jonas.orig     2004-09-01 16:16:26.418851544 +0100
+++ rhdb-jonas  2004-09-01 16:16:35.276504976 +0100
@@ -3,7 +3,7 @@
         notifempty
         nomail
        postrotate
-/etc/rc.d/init.d rhdb-jonas reload
+/etc/rc.d/init.d/rhdb-jonas reload
         endscript
         daily
 }
Comment 1 Permaine Cheung 2004-09-07 11:22:16 EDT
Thank you for reporting the bug, I also noticed that another problem
in this logrotate file, the first line should be 
/var/log/rhdb/rhdb-jonas {
instead of 
"/etc/logrotate.d/rhdb-jonas" {
because we should be rotating the log for rhdb-jonas instead of the
logrotate file itself.
Here's what the new patch looks like:
- "/etc/logrotate.d/rhdb-jonas" {
          copytruncate
          notifempty
          nomail
        postrotate
- /etc/rc.d/init.d rhdb-jonas reload
          endscript
          daily
  }
--- 1,9 ----
+ /var/log/rhdb/rhdb-jonas {
          copytruncate
          notifempty
          nomail
        postrotate
+ /etc/rc.d/init.d/rhdb-jonas reload
          endscript
          daily
  }
We'll be putting this fix in, and I'll update the status when that is
done.
Comment 2 Permaine Cheung 2004-09-16 11:54:53 EDT
Fixed, will be available in the next errata.

Note You need to log in before you can comment on or make changes to this bug.