Bug 1314498 - Calc adds cells together that shouldnt be added.
Calc adds cells together that shouldnt be added.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libreoffice (Show other bugs)
6.8
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Eike Rathke
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-03 13:53 EST by Bill Sanford
Modified: 2016-03-04 07:53 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-04 07:53:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen capture of the cells being addad (80.93 KB, image/png)
2016-03-03 13:53 EST, Bill Sanford
no flags Details

  None (edit)
Description Bill Sanford 2016-03-03 13:53:10 EST
Created attachment 1132894 [details]
screen capture of the cells being addad

Description of problem: 

In LO calc, I can add a text cell, a date cell and a currency cell and have the sum as an obfuscated total. When I edit the date field and change the days, months or years, the sum total changes to reflect the total that the date field thinks it is.

In each cell you format each one, respective of what they are. Format -> Cells -> Numbers Tab, in the Category box, select the format that each cell will represent. 


Version-Release number of selected component (if applicable):
RHEL-6.8-20160225.0
libreoffice-4.3.7.2-2

How reproducible:
100%

Steps to Reproduce:
1. See Above.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Bill Sanford 2016-03-03 15:58:39 EST
A date will have the value (In days) from 01/01/1900 to <DATE_ENTERED> on the sheet. Using that figure as an operand as a default action, seems like the #VALUE error should be raised until a setting in Calc has changed.
Comment 2 Eike Rathke 2016-03-04 07:53:18 EST
A date (+time) is just a numeric value, the number of days since null date (serial date number), formatted as date/time. You can see the underlying number when setting the number format to General. As it is a numeric value it can be calculated with as any other number. This is not a bug, this is how most spreadsheet applications handle date/time.

Note You need to log in before you can comment on or make changes to this bug.