Bug 1314733 - [WALA][rhel6]execute "service waagent start" twice will create two waagent daemon processes
[WALA][rhel6]execute "service waagent start" twice will create two waagent da...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: WALinuxAgent (Show other bugs)
6.7
Unspecified Linux
medium Severity medium
: rc
: ---
Assigned To: Yue Zhang
Virtualization Bugs
:
Depends On:
Blocks: 1366045 1359574 1387784
  Show dependency treegraph
 
Reported: 2016-03-04 06:19 EST by yuxisun@redhat.com
Modified: 2016-11-16 01:20 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-10 05:30:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yuxisun@redhat.com 2016-03-04 06:19:22 EST
Description of problem:
Every time we execute "service waagent start" it will create a daemon
process. If we execute "service waagent start" several times, there will be
more than one "python /usr/sbin/waagent -daemon" processes.
And running "service waagent stop" can only stop the latest process.

Version-Release number of selected component (if applicable):
WALinuxAgent-2.0.16-1.el6

How reproducible:
Always

Steps to Reproduce:
1. Prepare a VM with WALinuxAgent package installed.
# ps aux|grep waagent, there should be one "python /usr/sbin/waagent -daemon"
processes.
2. Excute "service waagent start".
3. Check the number of waagent daemon process.
# ps aux|grep waagent

Actual results:
There're two "python /usr/sbin/waagent -daemon" processes.

Expected results:
There's only one "python /usr/sbin/waagent -daemon" process.
No matter how many times we execute the start command, there should be only
one waagent daemon process.

Additional info:
rhel7 doesn't have this issue.
Comment 3 yuxisun@redhat.com 2016-08-10 05:30:14 EDT
Fixed in WALinuxAgent-2.1.5. Verify and close it.

*** This bug has been marked as a duplicate of bug 1360493 ***

Note You need to log in before you can comment on or make changes to this bug.