Bug 1314734 - [WALA]warning message is wrong while deprovisioning if don't delete ssh host key pairs
[WALA]warning message is wrong while deprovisioning if don't delete ssh host ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: WALinuxAgent (Show other bugs)
6.7
Unspecified Linux
low Severity low
: rc
: ---
Assigned To: Yue Zhang
Virtualization Bugs
:
Depends On:
Blocks: 1366045 1359574 1387784
  Show dependency treegraph
 
Reported: 2016-03-04 06:22 EST by yuxisun@redhat.com
Modified: 2016-11-16 01:20 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-09 04:38:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yuxisun@redhat.com 2016-03-04 06:22:15 EST
Description of problem:
If set "Provisioning.RegenerateSshHostKeyPair=n" in /etc/waagent.conf and
execute "waagent -deprovision", the ssh how key pairs will not be deleted.
But there is a message "WARNING! All SSH host key pairs will be deleted.".

Version-Release number of selected component (if applicable):
WALinuxAgent-2.0.16-1.el6

How reproducible:
Always

Steps to Reproduce:
1. Prepare a VM with WALinuxAgent installed.
2. Set RegenerateSshHostKeyPair=n in /etc/waagent.conf:
Provisioning.RegenerateSshHostKeyPair=n
3. Execute deprovision, and focus on the warning messages:
# waagent -deprovision

Actual results:
There's a message: "WARNING! All SSH host key pairs will be deleted."

Expected results:
There's no message: "WARNING! All SSH host key pairs will be deleted."
because the ssh host key pairs will not be deleted.

Additional info:
Comment 3 yuxisun@redhat.com 2016-08-09 04:38:25 EDT
This issue is fixed in WALinuxAgent-2.1.5. Verify and close it.

*** This bug has been marked as a duplicate of bug 1360493 ***

Note You need to log in before you can comment on or make changes to this bug.