Bug 1314791 - Switching windows with Alt+tab sometimes stop working after starting java application
Switching windows with Alt+tab sometimes stop working after starting java app...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-04 08:52 EST by Frode Arntsen
Modified: 2016-05-26 03:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-26 03:25:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frode Arntsen 2016-03-04 08:52:23 EST
Description of problem:

I've had this problem since upgrading to F23 from F22. It happens on average every 3rd time I start one of the two Java applications I'm using: IntelliJ Idea or DbVisualizer. I've tried starting these applications using both OpenJDK and Oracle's JDK, both in version 7 and 8, but the problem persists.

Quitting the application will make Alt+tab application switching work again.

In DbVisualizer actually opening the Help-->About.. windows actually makes Alt+tab work again. Closing the About window make the problem reappear. 

Version-Release number of selected component (if applicable):


How reproducible:
Easy.

Steps to Reproduce:
1. Start IntelliJ or DbVisualizer and check if Alt+tab still works
2. Quit the application
3. Repeat from step 1 until the problem occurs

Actual results:


Expected results:


Additional info:
This never happened prior to F23. Never seen this happening using any other application than these 2 java applications. It's possible that other java applications will trigger the same behaviour, but this I down't know.
Comment 1 Frode Arntsen 2016-03-04 09:17:36 EST
I'm not using Wayland.
Comment 2 Frode Arntsen 2016-04-25 05:22:14 EDT
It's the same when starting the java application yEd graph Editor. Seems to be a general problem in Gnome shell when starting java applications.
Comment 3 Frode Arntsen 2016-05-26 03:25:50 EDT
Seems to be fixed in F24.

Note You need to log in before you can comment on or make changes to this bug.