This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1314798 - LabPlot does not start from menu
LabPlot does not start from menu
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: LabPlot (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Mukundan Ragavan
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-04 09:20 EST by Christian Dersch
Modified: 2016-03-26 14:10 EDT (History)
4 users (show)

See Also:
Fixed In Version: LabPlot-2.1.0-9.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-26 08:38:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Dersch 2016-03-04 09:20:08 EST
Description of problem: LabPlot does not start from menu


Version-Release number of selected component (if applicable): 2.1.0-6.fc24


How reproducible: Always


Steps to Reproduce:
1. Install LabPlot at Fedora 24 or Rawhide
2. Try to start from menu

Actual results: LabPlot does not open


Expected results: LabPlot works fine


Additional info: I can start labplot2 at terminal, works fine then.

You can use an image from http://koji.fedoraproject.org/koji/taskinfo?taskID=13225103 to test, Astronomy Spin installs LabPlot by default
Comment 1 Mukundan Ragavan 2016-03-04 18:00:02 EST
Thanks for the report. Let me look.
Comment 2 Christian Dersch 2016-03-05 06:12:01 EST
Seems to be an issue with the .desktop file, the option --caption does not work with LabPlot.
Comment 3 Mukundan Ragavan 2016-03-11 20:57:53 EST
This should be fixed with this build - http://koji.fedoraproject.org/koji/buildinfo?buildID=744170

Closing. Please reopen if the issue persists.
Comment 4 Christian Dersch 2016-03-13 07:09:32 EDT
Thanks, please also push this to F24 :)
Comment 5 Christian Dersch 2016-03-13 07:13:55 EDT
uhm, just tried the Koji build 2.1.0-8.fc24, issue still there :( .desktop file still contains -caption
Comment 6 Christian Dersch 2016-03-13 07:17:20 EDT
Looks like you forgot -i option for sed in the spec file
Comment 7 Mukundan Ragavan 2016-03-13 14:36:02 EDT
(In reply to Christian Dersch from comment #6)
> Looks like you forgot -i option for sed in the spec file

Crap! :)

Ok, should definitely be fixed now.

F24 - https://koji.fedoraproject.org/koji/buildinfo?buildID=744454

Rawhide - https://koji.fedoraproject.org/koji/buildinfo?buildID=744453
Comment 8 Christian Dersch 2016-03-13 14:44:34 EDT
Looks good now, just a small reminder: Bodhi is now active for F24 too, so please push it as an update there too :) (The it will arrive in Astronomy spin soon too ;)
Comment 9 Mukundan Ragavan 2016-03-13 14:46:08 EDT
(In reply to Christian Dersch from comment #8)
> Looks good now, just a small reminder: Bodhi is now active for F24 too, so
> please push it as an update there too :) (The it will arrive in Astronomy
> spin soon too ;)

Just wanted a confirmation for you. :)

Will push now. Thanks for testing.
Comment 10 Fedora Update System 2016-03-13 14:47:00 EDT
LabPlot-2.1.0-9.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-9e104f1332
Comment 11 Fedora Update System 2016-03-15 17:32:18 EDT
LabPlot-2.1.0-9.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-9e104f1332
Comment 12 Mukundan Ragavan 2016-03-26 08:38:08 EDT
This update will be pushed to stable once the freeze is lifted after alpha release.
Comment 13 Fedora Update System 2016-03-26 14:10:01 EDT
LabPlot-2.1.0-9.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.