Bug 1314866 - Deleting a private flavor causes access issues with existing instances
Deleting a private flavor causes access issues with existing instances
Status: CLOSED DUPLICATE of bug 1326625
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
medium Severity medium
: ---
: 8.0 (Liberty)
Assigned To: Eoghan Glynn
nlevinki
: ZStream
Depends On:
Blocks: 1194008
  Show dependency treegraph
 
Reported: 2016-03-04 12:45 EST by Chris St. Pierre
Modified: 2016-04-13 04:45 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1326625 (view as bug list)
Environment:
Last Closed: 2016-04-13 04:43:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1366168 None None None 2016-03-10 11:06 EST
OpenStack gerrit 170839 None None None 2016-03-10 11:06 EST
OpenStack gerrit 211809 None None None 2016-03-10 11:08 EST

  None (edit)
Description Chris St. Pierre 2016-03-04 12:45:06 EST
Description of problem:

Deleting or modifying a private flavor causes various issues when displaying instances booted with that flavor: https://bugs.launchpad.net/nova/+bug/1366168

We'd like the pending upstream fix to be backported into OSP8.

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:

https://bugs.launchpad.net/nova/+bug/1366168/comments/17

Actual results:

https://bugs.launchpad.net/nova/+bug/1366168/comments/17

Expected results:

https://bugs.launchpad.net/nova/+bug/1366168/comments/17

Additional info:

Upstream patch is pending at https://review.openstack.org/#/c/211809/
Comment 3 Michal Pryc 2016-03-30 14:52:55 EDT
With the rework of the Flavors the Upstream change
https://review.openstack.org/#/c/211809/ will not be approved.

Nova engineering team will produce another fix for nova client that will
not fail when displaying instances with deleted private flavors.
Comment 4 Michal Pryc 2016-04-13 04:43:46 EDT

*** This bug has been marked as a duplicate of bug 1326625 ***

Note You need to log in before you can comment on or make changes to this bug.