Bug 1314898 - LCMS support broken in GraphicsMagick 1.3.23
LCMS support broken in GraphicsMagick 1.3.23
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: GraphicsMagick (Show other bugs)
el6
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-04 14:26 EST by Mason Malone
Modified: 2016-03-25 14:51 EDT (History)
1 user (show)

See Also:
Fixed In Version: GraphicsMagick-1.3.23-5.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-24 11:25:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
example TIFF that can reproduce the error (1.16 MB, image/tiff)
2016-03-04 14:26 EST, Mason Malone
no flags Details
ICC profile to reproduce the error (560 bytes, image/x-tga)
2016-03-04 14:28 EST, Mason Malone
no flags Details

  None (edit)
Description Mason Malone 2016-03-04 14:26:10 EST
Created attachment 1133233 [details]
example TIFF that can reproduce the error

Description of problem:

Upgrading GraphicsMagick from 1.3.20 to 1.3.23 on my CentOS 6.6 servers broke LCMS support. Attempting to use "gm convert" with an ICC profile now gives the error "LCMS encoding not enabled". I attached an image that can reproduce this.

$ wget http://twily.info/d/.icc/AdobeRGB1998.icc
$ gm convert 77095.f2.tif -profile AdobeRGB1998.icc foo.jpg
gm convert: LCMS encoding not enabled (77095.f2.tif).

Additionally, running "gm version" shows "Little CMS    no" under "Feature Support:". Before the upgrade, it said "yes".

Version-Release number of selected component (if applicable):
GraphicsMagick.x86_64-1.3.23-4.el6

How reproducible:
Always.

Steps to Reproduce:
1. Run "gm convert 77095.f2.tif -profile AdobeRGB1998.icc foo.jpg" with the attached TIFF in the latest version of GraphicsMagick. Notice the error.
2. Download and install the old version on a Centos 6.x box: https://kojipkgs.fedoraproject.org//packages/GraphicsMagick/1.3.20/3.el6/x86_64/GraphicsMagick-1.3.20-3.el6.x86_64.rpm
2. Run the command again. Now it succeeds.

Actual results:

gm convert: LCMS encoding not enabled (77095.f2.tif).

Expected results:

No output. foo.jpg created successfully.

Additional info:

I believe this happened because GraphicsMagick removed support for the legacy LCMS 1.x in version 1.3.22. Link to the commit: http://marc.info/?l=graphicsmagick-commit&m=143551691329485&w=2

However, GraphicsMagick.spec still tries to compile GraphicsMagick with "--with-lcms", which no longer does anything. Since LCMS2 is available for EL6, I think the spec file should be changed to always use LCMS2.
Comment 1 Mason Malone 2016-03-04 14:28 EST
Created attachment 1133234 [details]
ICC profile to reproduce the error
Comment 2 Fedora Update System 2016-03-04 15:51:05 EST
GraphicsMagick-1.3.23-5.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-da9cc78fe7
Comment 3 Fedora Update System 2016-03-04 20:52:11 EST
GraphicsMagick-1.3.23-5.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-da9cc78fe7
Comment 4 Fedora Update System 2016-03-09 10:12:13 EST
GraphicsMagick-1.3.23-5.el5 lcms2-2.7-3.el5 has been submitted as an update to Fedora EPEL 5. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-684ad9e4b8
Comment 5 Fedora Update System 2016-03-10 10:49:06 EST
GraphicsMagick-1.3.23-5.el5, lcms2-2.7-3.el5 has been pushed to the Fedora EPEL 5 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-684ad9e4b8
Comment 6 Fedora Update System 2016-03-24 11:25:37 EDT
GraphicsMagick-1.3.23-5.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2016-03-25 14:51:19 EDT
GraphicsMagick-1.3.23-5.el5, lcms2-2.7-3.el5 has been pushed to the Fedora EPEL 5 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.