Bug 1314920 - No logs when Git or Mock SCM import fails
No logs when Git or Mock SCM import fails
Status: CLOSED CURRENTRELEASE
Product: Copr
Classification: Community
Component: backend (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: clime
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-04 16:25 EST by Daniel Vrátil
Modified: 2016-03-29 08:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-29 08:18:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Vrátil 2016-03-04 16:25:16 EST
Description of problem:
When import fails, the build details page says

   "Import failed. See logs for more details. "

However there are no logs for the build available.

The obvious simple fix is to remove the "See logs...." sentence, however it would be much much much better if there were actual logs available, since it would make figuring out what went wrong much easier.

I had a problem with my Mock SCM repo having different name than the actual package and I spent almost an hour figuring what's wrong, until I eventually found the relevant code in Copr source and realized what's wrong - having the mock log available would've saved me bunch of time....

How reproducible:
always (when there's an import error)


Steps to Reproduce:
1. Have an error in Mock SCM data (wrong URL, invalid .spec path ...)
2. start build

Actual results:
Import fails, no logs available


Expected results:
Import fails, logs available :)
Comment 1 clime 2016-03-08 07:14:46 EST
Thank you for the suggestion. The added logs might prove quite useful.

Fixed by 4d6656bcf8d & 7623ba57f7.
Comment 2 Jakub Kadlčík 2016-03-15 04:51:48 EDT
Code with this fix is currently deployed on testing server.
You can test it before it will be deployed to production.
Please see: http://copr-fe-dev.cloud.fedoraproject.org
Comment 3 Jakub Kadlčík 2016-03-29 08:18:01 EDT
Copr production machines were upgraded to version containing a fix to this issue.
If you are not satisfied with provided solution, please feel free to reopen this.

Note You need to log in before you can comment on or make changes to this bug.