Bug 1314976 - nm-applet leaks memory with dbus connection
nm-applet leaks memory with dbus connection
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
: 1128766 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-05 06:36 EST by Zdenek Kabelac
Modified: 2016-03-11 04:59 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-08 10:04:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zdenek Kabelac 2016-03-05 06:36:19 EST
Description of problem:

26,880 (12,800 direct, 14,080 indirect) bytes in 320 blocks are definitely lost in loss record 15,568 of 15,581
   at 0x4C2DBAD: malloc (vg_replace_malloc.c:299)
   by 0x8697208: g_malloc (gmem.c:94)
   by 0x86AE2A2: g_slice_alloc (gslice.c:1025)
   by 0x86CC61C: g_variant_alloc (gvariant-core.c:476)
   by 0x86CC61C: g_variant_new_from_bytes (gvariant-core.c:512)
   by 0x86C5866: g_variant_new_from_trusted (gvariant.c:295)
   by 0x86C59ED: g_variant_new_uint32 (gvariant.c:484)
   by 0x7F4003F: parse_value_from_blob (gdbusmessage.c:1520)
   by 0x7F404FA: parse_value_from_blob (gdbusmessage.c:1848)
   by 0x7F40118: parse_value_from_blob (gdbusmessage.c:1768)
   by 0x7F40219: parse_value_from_blob (gdbusmessage.c:1721)
   by 0x7F402E1: parse_value_from_blob (gdbusmessage.c:1802)
   by 0x7F425D3: g_dbus_message_new_from_blob (gdbusmessage.c:2144)
   by 0x7F4CB1C: _g_dbus_worker_do_read_cb (gdbusprivate.c:718)
   by 0x7EE9C18: g_task_return_now (gtask.c:1107)
   by 0x7EE9C58: complete_in_idle_cb (gtask.c:1121)
   by 0x8691AB2: g_main_dispatch (gmain.c:3154)
   by 0x8691AB2: g_main_context_dispatch (gmain.c:3769)
   by 0x8691E5F: g_main_context_iterate.isra.29 (gmain.c:3840)
   by 0x8692181: g_main_loop_run (gmain.c:4034)
   by 0x7F4A935: gdbus_shared_thread_func (gdbusprivate.c:246)
   by 0x86B84A7: g_thread_proxy (gthread.c:780)
   by 0x895E699: start_thread (pthread_create.c:333)
   by 0x8C852CC: clone (clone.S:109)

26,936 bytes in 583 blocks are indirectly lost in loss record 15,569 of 15,581
   at 0x4C2DBAD: malloc (vg_replace_malloc.c:299)
   by 0x8697208: g_malloc (gmem.c:94)
   by 0x86B0037: g_memdup (gstrfuncs.c:391)
   by 0x866CB46: g_bytes_new (gbytes.c:96)
   by 0x86C5853: g_variant_new_from_trusted (gvariant.c:294)
   by 0x7F3FF3D: parse_value_from_blob (gdbusmessage.c:1591)
   by 0x7F40219: parse_value_from_blob (gdbusmessage.c:1721)
   by 0x7F404FA: parse_value_from_blob (gdbusmessage.c:1848)
   by 0x7F40118: parse_value_from_blob (gdbusmessage.c:1768)
   by 0x7F40219: parse_value_from_blob (gdbusmessage.c:1721)
   by 0x7F402E1: parse_value_from_blob (gdbusmessage.c:1802)
   by 0x7F425D3: g_dbus_message_new_from_blob (gdbusmessage.c:2144)
   by 0x7F4CB1C: _g_dbus_worker_do_read_cb (gdbusprivate.c:718)
   by 0x7EE9C18: g_task_return_now (gtask.c:1107)
   by 0x7EE9C58: complete_in_idle_cb (gtask.c:1121)
   by 0x8691AB2: g_main_dispatch (gmain.c:3154)
   by 0x8691AB2: g_main_context_dispatch (gmain.c:3769)
   by 0x8691E5F: g_main_context_iterate.isra.29 (gmain.c:3840)
   by 0x8692181: g_main_loop_run (gmain.c:4034)
   by 0x7F4A935: gdbus_shared_thread_func (gdbusprivate.c:246)
   by 0x86B84A7: g_thread_proxy (gthread.c:780)
   by 0x895E699: start_thread (pthread_create.c:333)
   by 0x8C852CC: clone (clone.S:109)


127,764 (13,360 direct, 114,404 indirect) bytes in 334 blocks are definitely lost in loss record 15,579 of 15,581
   at 0x4C2DBAD: malloc (vg_replace_malloc.c:299)
   by 0x8697208: g_malloc (gmem.c:94)
   by 0x86AE2A2: g_slice_alloc (gslice.c:1025)
   by 0x86CC6ED: g_variant_alloc (gvariant-core.c:476)
   by 0x86CC6ED: g_variant_new_from_children (gvariant-core.c:565)
   by 0x86C9433: g_variant_builder_end (gvariant.c:3615)
   by 0x7F4052E: parse_value_from_blob (gdbusmessage.c:1817)
   by 0x7F404FA: parse_value_from_blob (gdbusmessage.c:1848)
   by 0x7F40118: parse_value_from_blob (gdbusmessage.c:1768)
   by 0x7F40219: parse_value_from_blob (gdbusmessage.c:1721)
   by 0x7F402E1: parse_value_from_blob (gdbusmessage.c:1802)
   by 0x7F425D3: g_dbus_message_new_from_blob (gdbusmessage.c:2144)
   by 0x7F4CB1C: _g_dbus_worker_do_read_cb (gdbusprivate.c:718)
   by 0x7EE9C18: g_task_return_now (gtask.c:1107)
   by 0x7EE9C58: complete_in_idle_cb (gtask.c:1121)
   by 0x8691AB2: g_main_dispatch (gmain.c:3154)
   by 0x8691AB2: g_main_context_dispatch (gmain.c:3769)
   by 0x8691E5F: g_main_context_iterate.isra.29 (gmain.c:3840)
   by 0x8692181: g_main_loop_run (gmain.c:4034)
   by 0x7F4A935: gdbus_shared_thread_func (gdbusprivate.c:246)
   by 0x86B84A7: g_thread_proxy (gthread.c:780)
   by 0x895E699: start_thread (pthread_create.c:333)
   by 0x8C852CC: clone (clone.S:109)

and many others....

Version-Release number of selected component (if applicable):
network-manager-applet-1.2.0-0.3.beta1.fc24.x86_64

How reproducible:


Steps to Reproduce:
1. easy to obtain - just use valgrind...
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Zdenek Kabelac 2016-03-11 04:59:30 EST
*** Bug 1128766 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.