Bug 1315042 - [rfe]: Add yaourt style line numbers next to dnf search results
[rfe]: Add yaourt style line numbers next to dnf search results
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
All Linux
unspecified Severity low
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-06 01:01 EST by Alexander Kellermann
Modified: 2016-03-14 08:42 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-14 08:42:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Kellermann 2016-03-06 01:01:02 EST
Description of problem:

In Arch, you can install a CLI based program, which is basically a front end for Pacman. When you search using this tool, it generates the list of search results just like Fedora does when using 'dnf search *' but to the left of that, there is a column of numbers next to the search results. After this, to install the software you want, you put the number to the left of the name rather than the name itself. And to install multiple pieces of software you can either use common separated values [3,6,39] and to install a range you do [2-5]. This is a pretty nifty way of installing software, and I think the dnf package manager can benefit from this being at least an option, if not the default.
Comment 1 Jaroslav Mracek 2016-03-14 08:42:54 EDT
Thank you very much for presenting idea. It will be interesting possibilities if dnf will be interactive program, but we don't think it would be future in dnf. It also could be a problem, because name of the package could be a number. At that point it could create a confusion to dnf. Thank you for your time.

Note You need to log in before you can comment on or make changes to this bug.