Bug 1315050 - [abrt] tigervnc-server-minimal: vncGetPixelFormat(): Xvnc killed by SIGABRT
[abrt] tigervnc-server-minimal: vncGetPixelFormat(): Xvnc killed by SIGABRT
Status: CLOSED DUPLICATE of bug 1352099
Product: Fedora
Classification: Fedora
Component: tigervnc (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Grulich
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:ab9b34126bdfc661c220aa4d7c1...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-06 03:22 EST by Pavel Roskin
Modified: 2016-09-12 04:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-12 04:40:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (10.78 KB, text/plain)
2016-03-06 03:22 EST, Pavel Roskin
no flags Details
File: cgroup (200 bytes, text/plain)
2016-03-06 03:22 EST, Pavel Roskin
no flags Details
File: core_backtrace (1.57 KB, text/plain)
2016-03-06 03:22 EST, Pavel Roskin
no flags Details
File: dso_list (4.29 KB, text/plain)
2016-03-06 03:22 EST, Pavel Roskin
no flags Details
File: environ (246 bytes, text/plain)
2016-03-06 03:22 EST, Pavel Roskin
no flags Details
File: limits (1.29 KB, text/plain)
2016-03-06 03:22 EST, Pavel Roskin
no flags Details
File: maps (20.58 KB, text/plain)
2016-03-06 03:22 EST, Pavel Roskin
no flags Details
File: mountinfo (3.31 KB, text/plain)
2016-03-06 03:22 EST, Pavel Roskin
no flags Details
File: namespaces (85 bytes, text/plain)
2016-03-06 03:22 EST, Pavel Roskin
no flags Details
File: open_fds (434 bytes, text/plain)
2016-03-06 03:22 EST, Pavel Roskin
no flags Details
File: proc_pid_status (1.03 KB, text/plain)
2016-03-06 03:22 EST, Pavel Roskin
no flags Details
File: var_log_messages (224 bytes, text/plain)
2016-03-06 03:22 EST, Pavel Roskin
no flags Details

  None (edit)
Description Pavel Roskin 2016-03-06 03:22:10 EST
Description of problem:
I tried to connect to xrdp using 8 bpp. xrdp calls Xvnc.

Version-Release number of selected component:
tigervnc-server-minimal-1.6.0-1.fc23

Additional info:
reporter:       libreport-2.6.4
backtrace_rating: 3
cmdline:        Xvnc :10 -geometry 1024x768 -depth 8 -rfbauth /home/proski/.vnc/sesman_proski_passwd -bs -ac -nolisten tcp -localhost -dpi 96
crash_function: vncGetPixelFormat
executable:     /usr/bin/Xvnc
global_pid:     25021
kernel:         4.4.3-300.fc23.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (5 frames)
 #2 vncGetPixelFormat at vncExtInit.cc:87
 #3 vncExtensionInit at vncExtInit.cc:178
 #4 InitExtensions at ../../mi/miinitext.c:346
 #5 dix_main at main.c:208
 #7 _start
Comment 1 Pavel Roskin 2016-03-06 03:22:15 EST
Created attachment 1133453 [details]
File: backtrace
Comment 2 Pavel Roskin 2016-03-06 03:22:16 EST
Created attachment 1133454 [details]
File: cgroup
Comment 3 Pavel Roskin 2016-03-06 03:22:17 EST
Created attachment 1133455 [details]
File: core_backtrace
Comment 4 Pavel Roskin 2016-03-06 03:22:18 EST
Created attachment 1133456 [details]
File: dso_list
Comment 5 Pavel Roskin 2016-03-06 03:22:19 EST
Created attachment 1133457 [details]
File: environ
Comment 6 Pavel Roskin 2016-03-06 03:22:20 EST
Created attachment 1133458 [details]
File: limits
Comment 7 Pavel Roskin 2016-03-06 03:22:21 EST
Created attachment 1133459 [details]
File: maps
Comment 8 Pavel Roskin 2016-03-06 03:22:22 EST
Created attachment 1133460 [details]
File: mountinfo
Comment 9 Pavel Roskin 2016-03-06 03:22:24 EST
Created attachment 1133461 [details]
File: namespaces
Comment 10 Pavel Roskin 2016-03-06 03:22:24 EST
Created attachment 1133462 [details]
File: open_fds
Comment 11 Pavel Roskin 2016-03-06 03:22:25 EST
Created attachment 1133463 [details]
File: proc_pid_status
Comment 12 Pavel Roskin 2016-03-06 03:22:26 EST
Created attachment 1133464 [details]
File: var_log_messages
Comment 13 Jan Grulich 2016-09-12 04:40:50 EDT

*** This bug has been marked as a duplicate of bug 1352099 ***

Note You need to log in before you can comment on or make changes to this bug.