Bug 1315058 - SELinux is preventing qemu-kvm from 'write' accesses on the fifo_file fifo_file.
SELinux is preventing qemu-kvm from 'write' accesses on the fifo_file fifo_file.
Status: CLOSED DUPLICATE of bug 1305582
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
24
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:f048553f09145ecdb7fe39101b7...
:
: 1326358 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-06 05:44 EST by redhat
Modified: 2016-04-12 10:09 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-07 04:22:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description redhat 2016-03-06 05:44:37 EST
Description of problem:
When using virt-manager with a disk file in users home folder
SELinux is preventing qemu-kvm from 'write' accesses on the fifo_file fifo_file.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that qemu-kvm should be allowed write access on the fifo_file fifo_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep qemu-kvm /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:svirt_t:s0:c340,c358
Target Context                system_u:system_r:virtd_t:s0-s0:c0.c1023
Target Objects                fifo_file [ fifo_file ]
Source                        qemu-kvm
Source Path                   qemu-kvm
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-176.fc24.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.5.0-0.rc6.git2.1.fc24.x86_64 #1
                              SMP Thu Mar 3 18:43:44 UTC 2016 x86_64 x86_64
Alert Count                   1
First Seen                    2016-03-06 11:43:06 CET
Last Seen                     2016-03-06 11:43:06 CET
Local ID                      20821f98-8dbe-41cb-8e6d-0679b6d71df7

Raw Audit Messages
type=AVC msg=audit(1457260986.364:540): avc:  denied  { write } for  pid=7588 comm="qemu-kvm" path="pipe:[126363]" dev="pipefs" ino=126363 scontext=system_u:system_r:svirt_t:s0:c340,c358 tcontext=system_u:system_r:virtd_t:s0-s0:c0.c1023 tclass=fifo_file permissive=1


Hash: qemu-kvm,svirt_t,virtd_t,fifo_file,write

Version-Release number of selected component:
selinux-policy-3.13.1-176.fc24.noarch

Additional info:
reporter:       libreport-2.6.4
hashmarkername: setroubleshoot
kernel:         4.5.0-0.rc6.git2.1.fc24.x86_64
type:           libreport

Potential duplicate: bug 1303971
Comment 1 Lukas Slebodnik 2016-03-06 09:24:37 EST
Description of problem:
I boot my VM

Version-Release number of selected component:
selinux-policy-3.13.1-176.fc24.noarch

Additional info:
reporter:       libreport-2.6.4
hashmarkername: setroubleshoot
kernel:         4.5.0-0.rc5.git0.2.fc24.x86_64
type:           libreport
Comment 2 Lukas Vrabec 2016-03-07 04:22:47 EST

*** This bug has been marked as a duplicate of bug 1305582 ***
Comment 3 Stephen Gallagher 2016-04-12 10:09:40 EDT
*** Bug 1326358 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.