Bug 13151 - Setup creates unnecessary *.rpm{orig,new} files in /etc
Summary: Setup creates unnecessary *.rpm{orig,new} files in /etc
Status: CLOSED DUPLICATE of bug 12138
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: setup   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-28 05:29 UTC by Pekka Savola
Modified: 2014-03-17 02:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-03 14:00:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pekka Savola 2000-06-28 05:29:25 UTC
TUI Upgrade from custom RH62, with some files modified after the install.

Setup RPM seems to create a lot of unnecessary *.rpm{orig,new} files
in /etc:

----
csh.cshrc.rpmnew    host.conf.rpmnew    passwd.rpmnew sendmail.cw.rpmorig
csh.login.rpmnew    hosts.allow.rpmnew  printcap.rpmorig   services.rpmorig
exports.rpmorig     hosts.deny.rpmnew   profile.rpmnew
filesystems.rpmnew  inputrc.rpmorig     protocols.rpmorig
group.rpmnew        motd.rpmorig        securetty.rpmorig
----

Of these, diff showed that to the following there had been _no changes_ at
all:
----
exports
filesystems
host.conf
hosts.allow
hosts.deny
motd
printcap
protocols
----
From the scope of this, I dare say if I hadn't modified those shell startup
scripts, securetty, etc. myself before the upgrade, they'd have got a
"null" .rpm{orig,new} too. 


For these, such files shouldn't probably be created at all (but they were):
-----
group
passwd
-----

Comment 1 Telsa Gwynne 2000-07-03 14:00:32 UTC
Might want to merge this with bug 12138? Same thing.

Comment 2 Pekka Savola 2000-07-03 14:20:50 UTC

*** This bug has been marked as a duplicate of 12138 ***


Note You need to log in before you can comment on or make changes to this bug.