Bug 1315350 - TRACKER BUG: After adding network port to router , static route is not removed from options- metadata- enable_isolated_metadata = True
TRACKER BUG: After adding network port to router , static route is not remove...
Status: CLOSED UPSTREAM
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
8.0 (Liberty)
x86_64 Linux
unspecified Severity high
: ---
: 8.0 (Liberty)
Assigned To: Assaf Muller
Toni Freger
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-07 09:22 EST by Alexander Stafeyev
Modified: 2016-04-26 16:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-07 18:34:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1554066 None None None 2016-03-07 09:22 EST

  None (edit)
Description Alexander Stafeyev 2016-03-07 09:22:13 EST
Description of problem:
metadata- enable_isolated_metadata = True: After attaching network to router and restarting dhcp agent, static route is not removed from /var/lib/neutron/NID/opts

Version-Release number of selected component (if applicable):
[root@overcloud-controller-2 ~]# rpm -qa | grep neutr
openstack-neutron-common-7.0.1-10.el7ost.noarch
openstack-neutron-ml2-7.0.1-10.el7ost.noarch
openstack-neutron-openvswitch-7.0.1-10.el7ost.noarch
python-neutron-lbaas-7.0.0-2.el7ost.noarch
openstack-neutron-7.0.1-10.el7ost.noarch
openstack-neutron-metering-agent-7.0.1-10.el7ost.noarch
python-neutron-7.0.1-10.el7ost.noarch
openstack-neutron-lbaas-7.0.0-2.el7ost.noarch
python-neutronclient-3.1.0-1.el7ost.noarch


How reproducible:
100%

Steps to Reproduce:
1. Configure  enable_isolated_metadata = True in /etc/neutron/dhcp-agent.ini
2. Create Internal net and subnet. 
3. See there is a static route to 169.254.169.254 in dhcp options- 
cat /var/lib/neutron/dhcp/107277c1-ba33-4e50-93b2-750c8bc594a6/opts
tag:tag0,option:dns-server,10.35.28.28
tag:tag0,option:classless-static-route,169.254.169.254/32,192.168.2.1,0.0.0.0/0,192.168.2.1
tag:tag0,249,169.254.169.254/32,192.168.2.1,0.0.0.0/0,192.168.2.1
tag:tag0,option:router,192.168.2.1

4. Create a router. Attach network port to a router. Restart dhcp agent. 


Actual results:
the static route to 169.254.169.254 still exists

Expected results:
the static route to 169.254.169.254 should be removed. 


Additional info:
All extra info will be added when requested
Comment 2 Assaf Muller 2016-03-07 18:34:54 EST
Duplicate of upstream bug. This isn't specific to OSP, Director, RHEL or anything like that, so no need to track it specifically in RHBZ.

Note You need to log in before you can comment on or make changes to this bug.