Bug 1315358 - [abrt] ibus: bus_dbus_impl_connection_filter_cb(): ibus-daemon killed by SIGABRT
[abrt] ibus: bus_dbus_impl_connection_filter_cb(): ibus-daemon killed by SIGABRT
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:b24defc317ee932c47b15b9c24c...
:
: 1331678 1337508 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-07 09:35 EST by deadrat
Modified: 2016-05-19 07:10 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-18 01:29:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (14.18 KB, text/plain)
2016-03-07 09:35 EST, deadrat
no flags Details
File: cgroup (148 bytes, text/plain)
2016-03-07 09:36 EST, deadrat
no flags Details
File: core_backtrace (11.08 KB, text/plain)
2016-03-07 09:36 EST, deadrat
no flags Details
File: dso_list (2.05 KB, text/plain)
2016-03-07 09:36 EST, deadrat
no flags Details
File: environ (1.67 KB, text/plain)
2016-03-07 09:36 EST, deadrat
no flags Details
File: limits (1.29 KB, text/plain)
2016-03-07 09:36 EST, deadrat
no flags Details
File: maps (9.91 KB, text/plain)
2016-03-07 09:36 EST, deadrat
no flags Details
File: mountinfo (3.70 KB, text/plain)
2016-03-07 09:36 EST, deadrat
no flags Details
File: namespaces (85 bytes, text/plain)
2016-03-07 09:36 EST, deadrat
no flags Details
File: open_fds (1.63 KB, text/plain)
2016-03-07 09:36 EST, deadrat
no flags Details
File: proc_pid_status (1.04 KB, text/plain)
2016-03-07 09:36 EST, deadrat
no flags Details
File: var_log_messages (28 bytes, text/plain)
2016-03-07 09:36 EST, deadrat
no flags Details

  None (edit)
Description deadrat 2016-03-07 09:35:48 EST
Version-Release number of selected component:
ibus-1.5.11-1.fc23

Additional info:
reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        ibus-daemon --xim --panel disable
crash_function: bus_dbus_impl_connection_filter_cb
executable:     /usr/bin/ibus-daemon
global_pid:     1920
kernel:         4.4.3-300.fc23.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (9 frames)
 #4 bus_dbus_impl_connection_filter_cb at dbusimpl.c:1473
 #5 on_worker_message_about_to_be_sent at gdbusconnection.c:2343
 #6 _g_dbus_worker_emit_message_about_to_be_sent at gdbusprivate.c:465
 #7 continue_writing at gdbusprivate.c:1455
 #8 write_message_cb at gdbusprivate.c:1313
 #9 g_task_return_now at gtask.c:1106
 #10 complete_in_idle_cb at gtask.c:1120
 #15 gdbus_shared_thread_func at gdbusprivate.c:246
 #16 g_thread_proxy at gthread.c:778

Potential duplicate: bug 906086
Comment 1 deadrat 2016-03-07 09:35:58 EST
Created attachment 1133790 [details]
File: backtrace
Comment 2 deadrat 2016-03-07 09:36:05 EST
Created attachment 1133791 [details]
File: cgroup
Comment 3 deadrat 2016-03-07 09:36:09 EST
Created attachment 1133792 [details]
File: core_backtrace
Comment 4 deadrat 2016-03-07 09:36:11 EST
Created attachment 1133793 [details]
File: dso_list
Comment 5 deadrat 2016-03-07 09:36:15 EST
Created attachment 1133794 [details]
File: environ
Comment 6 deadrat 2016-03-07 09:36:18 EST
Created attachment 1133795 [details]
File: limits
Comment 7 deadrat 2016-03-07 09:36:21 EST
Created attachment 1133796 [details]
File: maps
Comment 8 deadrat 2016-03-07 09:36:22 EST
Created attachment 1133797 [details]
File: mountinfo
Comment 9 deadrat 2016-03-07 09:36:25 EST
Created attachment 1133798 [details]
File: namespaces
Comment 10 deadrat 2016-03-07 09:36:27 EST
Created attachment 1133799 [details]
File: open_fds
Comment 11 deadrat 2016-03-07 09:36:30 EST
Created attachment 1133800 [details]
File: proc_pid_status
Comment 12 deadrat 2016-03-07 09:36:32 EST
Created attachment 1133801 [details]
File: var_log_messages
Comment 13 fujiwara 2016-03-29 00:09:18 EDT
I cannot reproduce your backtrace.
Are you still able to reproduce your backtrace?

(In reply to rat from comment #1)
> Created attachment 1133790 [details]
> File: backtrace

#0  0x00007f4847f38a98 in __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:55
#1  0x00007f4847f3a69a in __GI_abort () at abort.c:89
#2  0x00007f48485519e5 in g_assertion_message (domain=domain@entry=0x55d42b175b3a "IBUS", file=file@entry=0x55d42b175fe6 "dbusimpl.c", line=line@entry=1473, func=func@entry=0x55d42b176620 <__func__.26086> "bus_dbus_impl_connection_filter_cb", message=message@entry=0x7f483000fa00 "assertion failed: (connection != NULL)") at gtestutils.c:2429
#3  0x00007f4848551a7a in g_assertion_message_expr (domain=domain@entry=0x55d42b175b3a "IBUS", file=file@entry=0x55d42b175fe6 "dbusimpl.c", line=line@entry=1473, func=func@entry=0x55d42b176620 <__func__.26086> "bus_dbus_impl_connection_filter_cb", expr=expr@entry=0x55d42b175ff1 "connection != NULL") at gtestutils.c:2444
#4  0x000055d42b165c56 in bus_dbus_impl_connection_filter_cb (dbus_connection=<optimized out>, message=0x55d42d095f20, incoming=0, user_data=0x55d42d083830) at dbusimpl.c:1473
#5  0x00007f4848b393ee in on_worker_message_about_to_be_sent (worker=<optimized out>, message=0x55d42d095f20, user_data=0x7f4834007320) at gdbusconnection.c:2343
#6  0x00007f4848b4ea75 in _g_dbus_worker_emit_message_about_to_be_sent (message=0x55d42d095f20, worker=0x7f4834005f20) at gdbusprivate.c:465
#7  continue_writing (worker=0x7f4834005f20) at gdbusprivate.c:1455
#8  0x00007f4848b4f02f in write_message_cb (source_object=<optimized out>, res=<optimized out>, user_data=0x55d42d1fb8c0) at gdbusprivate.c:1313
#9  0x00007f4848af25a3 in g_task_return_now (task=0x7f4830002ac0) at gtask.c:1106
#10 0x00007f4848af25d9 in complete_in_idle_cb (task=0x7f4830002ac0) at gtask.c:1120
#11 0x00007f484852be3a in g_main_dispatch (context=0x55d42d102b50) at gmain.c:3154
Comment 14 deadrat 2016-04-15 07:35:24 EDT
(In reply to fujiwara from comment #13)
> I cannot reproduce your backtrace.
> Are you still able to reproduce your backtrace?
> 
Hi, I am sorry, but I don't know how to reproduce the backtrace. 
I am not technically sound. 

If you meant to ask if I could reproduce the issue, the answer is no. 
Honestly I just submitted because it showed up in problem reporting tool. But If there is anything I can do to provide more info, I am happy to help.
Comment 15 fujiwara 2016-04-18 01:29:16 EDT
(In reply to rat from comment #14)
> (In reply to fujiwara from comment #13)
> > I cannot reproduce your backtrace.
> > Are you still able to reproduce your backtrace?
> > 
> Hi, I am sorry, but I don't know how to reproduce the backtrace. 
> I am not technically sound. 

When you filed this issue with abrt, abrt retrieved the backtrace and you could check it on GUI before you actually submit it.

> 
> If you meant to ask if I could reproduce the issue, the answer is no. 
> Honestly I just submitted because it showed up in problem reporting tool.
> But If there is anything I can do to provide more info, I am happy to help.

If you will reproduce your backtrace again, please comment here.
Comment 16 Vitalii Cherniak 2016-04-29 04:55:20 EDT
*** Bug 1331678 has been marked as a duplicate of this bug. ***
Comment 17 modee skor 2016-05-19 07:10:32 EDT
*** Bug 1337508 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.