Bug 1315416 - isolated capsule puppet latest events shows puppet events from default capsule
isolated capsule puppet latest events shows puppet events from default capsule
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Capsule (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high (vote)
: GA
: --
Assigned To: Shlomi Zadok
Kedar Bidarkar
http://projects.theforeman.org/issues...
: Triaged
: 1327700 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-07 11:49 EST by Kedar Bidarkar
Modified: 2016-07-27 07:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 07:31:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 14748 None None None 2016-04-22 11:11 EDT

  None (edit)
Description Kedar Bidarkar 2016-03-07 11:49:04 EST
Description of problem:

isolated capsule puppet latest events shows puppet events from default capsule

Version-Release number of selected component (if applicable):
Sat6.2.0-Beta-SNAP2

How reproducible:


Steps to Reproduce:
1. provision a new host in default cpasule with puppet or configure a host with puppet
2. Setup capsule and navigate to the capsule show page
3. Look for the "Latest Events"

Actual results:
isolated capsule puppet latest events shows puppet events from default capsule

Expected results:
 I believe isolated capsule's puppet latest events should show puppet events only from isolated capsule and not from default capsule.

Additional info:
Comment 4 Brad Buckingham 2016-04-18 12:01:12 EDT
*** Bug 1327700 has been marked as a duplicate of this bug. ***
Comment 5 Brad Buckingham 2016-04-18 12:02:03 EDT
Refer to bug 1327700, for a video that also illustrates the behavior.
Comment 7 Shlomi Zadok 2016-04-21 06:27:03 EDT
Created redmine issue http://projects.theforeman.org/issues/14748 from this bug
Comment 8 Bryan Kearney 2016-04-21 08:07:15 EDT
Upstream bug component is Capsule
Comment 9 Bryan Kearney 2016-04-21 14:05:57 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/14748 has been closed
-------------
Shlomi Zadok
Applied in changeset commit:9fb6675f32aa673fe8745faa1501f43b09a6d408.
Comment 10 Kedar Bidarkar 2016-05-23 08:49:24 EDT
VERIFIED With sat62-snap12.1


We no longer see the puppet latest events from other capsules.
Comment 11 Bryan Kearney 2016-07-27 07:31:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.