Bug 1315438 - Mouse click issues with dual monitors
Mouse click issues with dual monitors
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
24
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
RejectedFreezeException
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-07 13:01 EST by Stephen Gallagher
Modified: 2016-09-22 14:12 EDT (History)
3 users (show)

See Also:
Fixed In Version: xorg-x11-server-1.18.2-2.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-22 14:12:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gallagher 2016-03-07 13:01:05 EST
Description of problem:
I have two monitors, one the internal 1920x1080 flat panel on the laptop and a second external 2560x1440 displayport monitor. The external monitor is configured as the primary display in GNOME and the laptop monitor is arranged to the right.

When running GNOME on Wayland, I cannot click anywhere on the primary monitor below the 1080-th line and anywhere on the laptop monitor when using an X11 application. (Wayland applications work properly.)

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.18.1-2.fc24.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Load the latest packages as of this writing on Fedora 24
2. Start a GNOME session on Wayland
3. Set up two monitors as described above
4. Try to click or click and drag on various parts of an X11 app running under XWayland in various places on the screen.

Actual results:
Mouse clicks do not work on the secondary monitor at all or below the Y size of the secondary monitor on the primary monitor on X11 apps.

Expected results:
Mouse clicks should work on both X11 and Wayland apps

Additional info:

Upstream patches that fix the issue:
https://cgit.freedesktop.org/xorg/xserver/commit/?id=2116f03
https://cgit.freedesktop.org/xorg/xserver/commit/?id=e957a2

I have tested this with a scratch build http://koji.fedoraproject.org/koji/taskinfo?taskID=13261226 and it resolves the issue (it applies the above two patches).

Please create an official build with those patches.
Comment 1 Fedora Blocker Bugs Application 2016-03-11 13:42:19 EST
Proposed as a Freeze Exception for 24-final by Fedora user sgallagh using the blocker tracking app because:

 Despite not yet being the default session, Wayland support is still very much in users' minds for Fedora 24. This is a very serious bug when dealing with multi-monitor support on a Wayland session, so I think it would be best to have it fixed in the Alpha release if possible.
Comment 2 Stephen Gallagher 2016-03-14 11:18:44 EDT
Whoops, accidentally proposed this for Final when I intended Alpha.
Comment 3 Kamil Páral 2016-03-14 13:33:43 EDT
Discussed at today's blocker review meeting [1]. Voted as RejectedFreezeException (Alpha) - this only affects Wayland and all deliverables use X11 by default, so an update should be sufficient for addressing this.

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2016-03-14/
Comment 4 Stephen Gallagher 2016-03-21 06:29:38 EDT
I can verify that this is fixed in xorg-x11-server-1.18.2-2.fc24

Note You need to log in before you can comment on or make changes to this bug.