Bug 1315553 - Not clear enough of MariaDB Galeara cluster operation
Not clear enough of MariaDB Galeara cluster operation
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity medium
: ga
: 8.0 (Liberty)
Assigned To: Don Domingo
Radek Bíba
: Documentation
Depends On: 1292511
Blocks: 1329020
  Show dependency treegraph
 
Reported: 2016-03-07 22:56 EST by Shinobu KINJO
Modified: 2016-07-11 03:47 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1329020 (view as bug list)
Environment:
Last Closed: 2016-07-11 03:47:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shinobu KINJO 2016-03-07 22:56:47 EST
Description of problem:

[Motivation] & [Background]

Red Hat will provide high availability the OpenStack architecture.[1]
On top of this architecture, there is clustered database using:

 MariaDB [2]
 Galera [3]

Galera configures MariaDB as cluster. [4]

This architecture provides the customers with really really high availability:
Let's say The cluster on the cluster

This solution is pretty good regarding to:

 1.Scalability
 2.Reliability

Both of them are very important factors for the customers.
But there is one important weak point.

 1.Complexity

They are quite good enough complex for the customers to operate.
Especially in case of disaster, they have *no* idea what's going on behind the clustered system.

To fix negativeness, Red Hat has to provide them with reasonable and understandable guide.

Since we will *not* be on the way to provide single node, *zero* redundant architecture in the future, it's going to be more important for us to make good progress and get much more trust from every single customer with OSP(> 7).

Please consider making a guide for MariaDB Galera cluster running on top of the Pacemaker.
I will be willing to help you make it successful. 

 [1]http://goo.gl/k86hSb
 [2]https://mariadb.org/
 [3]http://galeracluster.com/products/
 [4]https://mariadb.com/kb/en/mariadb/what-is-mariadb-galera-cluster/

Cheers,

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 15 Andrew Dahms 2016-05-03 09:13:56 EDT
Assigning Radek as the QA contact.

Radek - can you take a look at the changes for this bug?
Comment 16 Radek Bíba 2016-05-04 04:36:28 EDT
Looks good to me. General notes regarding the HA guide are in the other two bugs.
Comment 17 Andrew Dahms 2016-07-11 03:47:50 EDT
This content is now live on the Customer Portal.

Closing.

Note You need to log in before you can comment on or make changes to this bug.