Bug 1315593 - [RFE] grub.conf has the last installed kernel as default boot kernel instead of the latest installed version as default
[RFE] grub.conf has the last installed kernel as default boot kernel instead ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: grubby (Show other bugs)
6.6
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Peter Jones
Release Test Team
: FutureFeature
Depends On:
Blocks: 1269194
  Show dependency treegraph
 
Reported: 2016-03-08 02:53 EST by Seiji Nishikawa
Modified: 2016-08-18 08:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-25 14:30:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Seiji Nishikawa 2016-03-08 02:53:19 EST
Description of problem:

grub.conf has the last installed kernel as a default boot kernel instead of the latest installed version of kernel as default.

Version-Release number of selected component (if applicable):

kernel-2.6.32-504.3.3.el6.x86_64
grub-0.97-83.el6.x86_64   
grubby-7.0.15-5.el6.x86_64


How reproducible:

Always

Steps to Reproduce:

1. Install the latest kernel e.g. kernel-2.6.32-573.el6.

2. Next install the older kernel than the one installed in step 1 e.g. kernel-2.6.32-431.el6.

3. The older kernel (in this example 2.6.32-431.el6) installed in step 2 is set as a default boot kernel in grub.conf instead of the latest version of installed kernel (in this example 2.6.32-573.el6).

Actual results:

The last installed kernel will always be a default boot kernel in grub.conf instead of the latest installed version of kernel. If an older kernel is getting installed after the newer version of kernel, we will have to manually update grub.conf to use the newer version of kernel.

Expected results:

We should like to have some option/way being introduced to update grub.conf to use latest version of kernel as the default boot kernel instead of last installed kernel.

Additional info:

Customer uses HP server automation tool which is used in the IT infrastructures to do the automation of the operations that are done at server OS level including kernel installation, which brings multiple versions of kernels installed at the same time; resulting in older kernel being set as a default boot kernel in grub.conf at times. We sould like to provide our customer with some good option/way to update grub.conf to always use the latest installed version of kernel as a default boot kernel.
Comment 2 David Kaspar [Dee'Kej] 2016-03-08 10:20:22 EST
Hello Seiji,

I personally see the current behaviour as expected and I wouldn't definitely change the default behaviour of this. Most likely scenario is that end-user will install the older kernel because the latest/newer one isn't stable. In that case it desirable to boot into the older kernel, which should be in most cases more stable.

However, if the customer requires such a behaviour, introducing a new option for this is IMHO a good way to do it.

Nevertheless, grub is working correctly in this case (it does what it's suppose to do, by following instructions in grub.conf). Therefore, I'm switching this to grubby package, which is a configuration tool for grub.
Comment 3 Chris Williams 2016-07-25 14:30:06 EDT
When Red Hat shipped 6.8 on May 10, 2016 RHEL 6 entered Production Phase 2. 
https://access.redhat.com/support/policy/updates/errata#Production_2_Phase
That means only "Critical and Important Security errata advisories (RHSAs) and Urgent Priority Bug Fix errata advisories (RHBAs) may be released"
That also means no new RFEs so this BZ is being closed WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.