Bug 131565 - conflicts between eclipse-gtk2-3.0.0-22 and eclipse-2.1.2-8
Summary: conflicts between eclipse-gtk2-3.0.0-22 and eclipse-2.1.2-8
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: eclipse (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tom Tromey
QA Contact: eclipse-bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-02 11:35 UTC by David Juran
Modified: 2014-08-11 05:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 21:27:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Juran 2004-09-02 11:35:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20040803

Description of problem:
I subcribed a computer that had eclipse-2.1.2-5 installed to the 
rhel-3-ws-i386-rhds-2 channel and then ran up2date -u.
After a while it died with the following traceback:

Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1174, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 772, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 1066, in batchRun
    batch.run()
  File "up2dateBatch.py", line 86, in run
  File "up2dateBatch.py", line 170, in __installPackages
  File "up2date.py", line 692, in installPackages
  File "up2date.py", line 580, in runTransaction
  File "rpmUtils.py", line 511, in runTransaction
up2date_client.up2dateErrors.TransactionError: RPM  error. The message
was:
Failed running transaction of  packages: 
('file /usr/lib/eclipse/eclipse conflicts between attempted installs
of eclipse-gtk2-3.0.0-22 and eclipse-2.1.2-8', (6,
'/usr/lib/eclipse/eclipse', 0L))
('file /usr/bin/eclipse conflicts between attempted installs of
eclipse-scripts-3.0.0-22 and eclipse-2.1.2-8', (6, '/usr/bin/eclipse',
0L))
('file /usr/share/applications/eclipse.desktop conflicts between
attempted installs of eclipse-scripts-3.0.0-22 and eclipse-2.1.2-8',
(6, '/usr/share/applications/eclipse.desktop', 0L))


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. subscribe to rhel-i386-ws-3-devsuite
2. install eclipse
3. Now add the computer to the rhel-3-ws-i386-rhds-2 channel as well
4. run up2date -u    

Additional info:

Comment 1 Aaron Luchko 2004-09-02 21:27:42 UTC
Red Hat Developer Suite 2.0 is the first supported version of
Developer Suite.  As a result there is no supported upgrade path from
Developer Suite 1.0.  In order to install Developer Suite 2.0 you'll
first need to uninstall Developer Suite 1.0.


Note You need to log in before you can comment on or make changes to this bug.