Bug 1315728 - cannot use more states for filtering tasks
cannot use more states for filtering tasks
Status: CLOSED WONTFIX
Product: Red Hat Storage Console
Classification: Red Hat
Component: core (Show other bugs)
2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3
Assigned To: gowtham
sds-qe-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-08 08:31 EST by Martin Kudlej
Modified: 2017-03-23 00:03 EDT (History)
4 users (show)

See Also:
Fixed In Version: rhscon-ceph-0.0.23-1.el7scon.x86_64, rhscon-core-0.0.24-1.el7scon.x86_64, rhscon-ui-0.0.39-1.el7scon.noarch
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-23 00:03:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kudlej 2016-03-08 08:31:45 EST
Description of problem:
I have 24 completed tasks(and subtasks) and 8 of them are failed. I write about "Total numbers" not about visible ones, see bug 1315716
Filtering according state gives me strange results:
1) Inprogress==True, Completed==True, Failed==True => 8 failed tasks
2) Inprogress==True, Completed==True, Failed==False => all 24 tasks

So I think "Inprogress" and "Completed" should be designed as radiobuttons and then there should be another pair of radiobuttons with "Failed" and "Passed"

Version-Release number of selected component (if applicable):
rhscon-core-0.0.8-11.el7.x86_64
rhscon-ui-0.0.20-1.el7.noarch
rhscon-ceph-0.0.6-11.el7.x86_64

How reproducible:
100%
Comment 1 Matt Carrano 2016-03-14 16:47:16 EDT
Sounds like this is not working as designed.  The count displayed here should be the number of items that select the criteria, if In Progress, Completed, and Failed are all selected, then all tasks are displayed (in this case 24 tasks).  If I set Failed = false, then the user should only see tasks that are either in progress or that have been completed successfully (16 tasks in this case).
Comment 2 Karnan 2016-05-25 06:17:25 EDT
@Matt Carrano - What should be displayed when none of the filters are selected

Inprogress==False, Completed==False, Failed==False
Comment 3 Matt Carrano 2016-05-25 10:26:16 EDT
(In reply to Karnan from comment #2)
> @Matt Carrano - What should be displayed when none of the filters are
> selected
> 
> Inprogress==False, Completed==False, Failed==False

If no filters are selected, then there is nothing to show and you should display an "empty state."  See https://www.patternfly.org/patterns/table-view/  for guidance on what this should look like.

I suggest a message like, "There are no tasks that meet your criteria.  Please select In Progress, Completed, and/or failed to list all tasks that meet that criteria."

I'm also comparing against the design and see that "Succeeded" was changes to "Completed."  This may result in confusion as identified in the original bug.  What you call "Completed" should only be tasks that have completed successfully.
Comment 4 Martin Kudlej 2016-07-14 06:50:07 EDT
Tested with 
ceph-ansible-1.0.5-25.el7scon.noarch
ceph-installer-1.0.12-4.el7scon.noarch
rhscon-ceph-0.0.32-1.el7scon.x86_64
rhscon-core-0.0.33-1.el7scon.x86_64
rhscon-core-selinux-0.0.33-1.el7scon.noarch
rhscon-ui-0.0.47-1.el7scon.noarch
and it is not fixed as is described in comment #3
1) If no filter is selected all tasks are shown.
2) Succeeded is renamed to Completed which is I think wrong because Failed tasks are completed too.
3) Missing implementation of cite: "Filter events by name, object or other criteria (e.g. object, user, etc.)." It seems that it searches in all attributes but this should be specified somewhere or implemented according design document.
-->Assigned

Note You need to log in before you can comment on or make changes to this bug.