Bug 1315733 - filtering in tasks list should be obvious
filtering in tasks list should be obvious
Status: CLOSED WONTFIX
Product: Red Hat Storage Console
Classification: Red Hat
Component: UI (Show other bugs)
2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3
Assigned To: sankarshan
sds-qe-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-08 08:39 EST by Martin Kudlej
Modified: 2017-03-23 00:12 EDT (History)
3 users (show)

See Also:
Fixed In Version: rhscon-ui-0.0.23-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-23 00:12:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kudlej 2016-03-08 08:39:56 EST
Description of problem:
I think user should know if any filter is used. If tasks list page is opened for first time no filter is apply but it is not obvious that tasks are not filtered because there are dates and times filled by default.
Also user should know if there is current list of filtered tasks because showing result after clicking on "Filter" button and takes significant time.

Version-Release number of selected component (if applicable):
rhscon-core-0.0.8-11.el7.x86_64
rhscon-ui-0.0.20-1.el7.noarch
rhscon-ceph-0.0.6-11.el7.x86_64

How reproducible:
100%
Comment 1 Matt Carrano 2016-03-14 16:50:00 EDT
This is a valid issue and more UX design guidance will be given on detailed interactions for list filters.
Comment 3 Martin Kudlej 2016-07-14 07:12:13 EDT
It is obvious what filter is selected.
It is not obvious if task list is loading or it is already loaded after selecting filter. I think there should be implemented loading indicator. User should know if filter is already applied. --> Assigned

Note You need to log in before you can comment on or make changes to this bug.