Bug 131579 - bonding and default gateway problem
Summary: bonding and default gateway problem
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: initscripts   
(Show other bugs)
Version: 2.1
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-02 14:36 UTC by Radek Bohunsky
Modified: 2014-03-17 02:47 UTC (History)
2 users (show)

Fixed In Version: 7.31.27.EL-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 21:16:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Change between 7.31.13 and 7.31.16 in ifup-aliases (678 bytes, text/plain)
2004-09-20 23:39 UTC, aaron ross
no flags Details

Description Radek Bohunsky 2004-09-02 14:36:23 UTC
Description of problem:
in last version of initscripts some changes was made to bonding part
of ifup script. After this change the rebooted machine, with bonding
over two interfaces, doesn't set default gateway routing rule and is
accessible only from its subnet. If I only run
/etc/rc.d/init.d/network restart, routes are correct.
/sbin/ifup for eth0 and eth1 is now called after "ip route add
default" in ifup script. When I tried to move this ifups before "ip
route add", gateway was set correctly.
I added line to /etc/sysconfig/static-routes to workaround this problem.

Version-Release number of selected component (if applicable):
initscripts-6.47.10-1

How reproducible:
always

Steps to Reproduce:
reboot server (maybe stop networking and remove of modules is
sufficient, I didn't try)
  
Actual results:
default gateway isn't set

Expected results:
route
default         192.168.10.1    0.0.0.0         UG    0      0       
0 bond0

Additional info:
::::::::::::::
/etc/modules.conf
::::::::::::::
alias eth0 bcm5700
alias eth1 bcm5700
alias bond0 bonding
options bond0 miimon=100 mode=active-backup downdelay=1000
updelay=1000 primary=eth0
::::::::::::::
/etc/sysconfig/network-scripts/ifcfg-bond0
::::::::::::::
DEVICE=bond0
ONBOOT=yes
BOOTPROTO=static
IPADDR=192.168.10.41
NETMASK=255.255.255.0
GATEWAY=192.168.10.1
::::::::::::::
/etc/sysconfig/network-scripts/ifcfg-eth0
::::::::::::::
DEVICE=eth0
ONBOOT=yes
BOOTPROTO=none
MASTER=bond0
SLAVE=yes
::::::::::::::
/etc/sysconfig/network-scripts/ifcfg-eth1
::::::::::::::
DEVICE=eth1
ONBOOT=yes
BOOTPROTO=none
MASTER=bond0
SLAVE=yes

Comment 1 aaron ross 2004-09-20 23:39:40 UTC
Created attachment 104046 [details]
Change between 7.31.13 and 7.31.16 in ifup-aliases

Comment 2 aaron ross 2004-09-20 23:40:54 UTC
The change in the attachment has broken bonding for us. The default
gateway does not get set on the machine at all.

Comment 3 Bill Nottingham 2004-09-21 05:20:01 UTC
Reverting *only* that change fixes it for you? You don't appear to be
using bonding + aliases.

Comment 4 Radek Bohunsky 2004-09-22 08:43:29 UTC
to Bill: configs from bug report from me are not tied with problem
from comments #1 and #2 from aaron ross. Probably it's similar problem
in another part of initscripts.

Comment 5 Sébastien BONNET 2005-08-22 21:09:19 UTC
I have the exact same problem running ES 3 update 5. Initscript is 7.31.22.EL-2.

My hack was to add the refault route to /etc/rc.local. Not so nice :(

Comment 6 Bill Nottingham 2005-09-21 21:16:01 UTC
Since this bugzilla report was filed, there have been several updates to
initscripts which may resolve this issue. Red Hat recommends updating to the
latest release. If this problem persists, please open a new bug with your
pertinent configuration information.


Note You need to log in before you can comment on or make changes to this bug.