Bug 131584 - up2date shows traceback errors randomly (when server is down?)
up2date shows traceback errors randomly (when server is down?)
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
Fanny Augustin
:
Depends On:
Blocks: 120092 130798
  Show dependency treegraph
 
Reported: 2004-09-02 11:52 EDT by Chaskiel Grundman
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:19:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chaskiel Grundman 2004-09-02 11:52:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040614 Firefox/0.8

Description of problem:
In the last few days, I've started noticing that up2date fails about
half the time on my RHEL3-U2 machines. I updated one of them to
RHEl-U3 and it still has the problem.

I do not think this is a duplicate of 130637. 
The backtrace is different, for one thing...

My suspicion (given where the error occurs, and the fact that I have
seen occasional failures of the rhn web interface since the upgrade on
tuesday) that this error is somehow triggered by a server failure.

If I run up2date with -vv, the 'D: logininfo:...' and 'D:
availablePackageList::channels:' lines appear before the traceback occurs.

Version-Release number of selected component (if applicable):
up2date-4.2.38-1

How reproducible:
Sometimes

Steps to Reproduce:
1. run up2date -u (or up2date up2date, or...) (the 'Expected' output
below is for an already up-to-date system)

Actual Results:  https://xmlrpc.rhn.redhat.com/XMLRPC
https://xmlrpc.rhn.redhat.com/XMLRPC

Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1174, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 772, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 1066, in batchRun
    batch.run()
  File "up2dateBatch.py", line 62, in run
  File "up2dateBatch.py", line 97, in __findPackagesToUpdate
  File "packageList.py", line 157, in addGlobs
  File "rhnPackageInfo.py", line 232, in getAvailablePackageList
  File "rhnPackageInfo.py", line 150, in availablePackageList
  File "repoDirector.py", line 64, in initRepoDirector
  File "/usr/share/rhn/up2date_client/repoBackends/up2dateRepo.py",
line 345, in register
    up2dateRepo = Up2dateRepo()
  File "/usr/share/rhn/up2date_client/repoBackends/up2dateRepo.py",
line 304, in __init__
    serverSettings)
  File "/usr/share/rhn/up2date_client/repoBackends/up2dateRepo.py",
line 247, in getGETServer
    server= rpcServer.RetryGETServer(serverSettings.serverList.server(),
  File "rpcServer.py", line 103, in server
IndexError: list index out of range


Expected Results:  
Invalid group id server-cfg

Fetching Obsoletes list for channel: rhel-i386-ws-3...

Fetching rpm headers...

Name                                    Version        Rel     
----------------------------------------------------------

All packages are currently up to date



Additional info:
Comment 1 RHEL Product and Program Management 2007-10-19 15:19:30 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.