Bug 1315938 - Mouse cursor invisible in Gnome3
Mouse cursor invisible in Gnome3
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: mutter (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Florian Müllner
Fedora Extras Quality Assurance
:
: 1316250 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-08 23:04 EST by olegon.ru
Modified: 2016-03-10 10:53 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-10 10:53:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Video showing the problem (566.80 KB, application/octet-stream)
2016-03-09 12:05 EST, olegon.ru
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 763159 None None None 2016-03-10 10:52 EST

  None (edit)
Description olegon.ru 2016-03-08 23:04:59 EST
Description of problem:

Mouse cursor disappeared, when moving above any gnome-window or menu.

Version-Release number of selected component (if applicable):

gnome-classic-session.noarch                                                           3.18.4-1.fc23                                          @updates        
gnome-clocks.x86_64                                                                    3.18.0-1.fc23                                          @koji-override-0
gnome-color-manager.x86_64                                                             3.18.0-1.fc23                                          @koji-override-0
gnome-desktop3.x86_64                                                                  3.18.2-1.fc23                                          @updates        
gnome-disk-utility.x86_64                                                              3.18.3.1-1.fc23                                        @updates        
gnome-font-viewer.x86_64                                                               3.16.2-3.fc23                                          @koji-override-0
gnome-keyring.x86_64                                                                   3.18.3-1.fc23                                          @updates        
gnome-keyring-pam.x86_64                                                               3.18.3-1.fc23                                          @updates        
gnome-menus.x86_64                                                                     3.13.3-4.fc23                                          @koji-override-0
gnome-online-accounts.x86_64                                                           3.18.4-1.fc23                                          @updates        
gnome-screenshot.x86_64                                                                3.18.0-1.fc23                                          @koji-override-0
gnome-session.x86_64                                                                   3.18.1.2-2.fc23                                        @updates        
gnome-session-wayland-session.x86_64                                                   3.18.1.2-2.fc23                                        @updates        
gnome-session-xsession.x86_64                                                          3.18.1.2-2.fc23                                        @updates        
gnome-settings-daemon.x86_64                                                           3.18.2-1.fc23                                          @updates        
gnome-shell.x86_64                                                                     3.18.4-1.fc23                                          @updates        
gnome-shell-extension-alternate-tab.noarch                                             3.18.4-1.fc23                                          @updates        
gnome-shell-extension-apps-menu.noarch                                                 3.18.4-1.fc23                                          @updates        
gnome-shell-extension-background-logo.noarch                                           3.18.0-1.fc23                                          @koji-override-0
gnome-shell-extension-common.noarch                                                    3.18.4-1.fc23                                          @updates        
gnome-shell-extension-launch-new-instance.noarch                                       3.18.4-1.fc23                                          @updates        
gnome-shell-extension-places-menu.noarch                                               3.18.4-1.fc23                                          @updates        
gnome-shell-extension-user-theme.noarch                                                3.18.4-1.fc23                                          @updates        
gnome-shell-extension-window-list.noarch                                               3.18.4-1.fc23                                          @updates        
gnome-system-monitor.x86_64                                                            3.18.2-1.fc23                                          @updates        
gnome-terminal.x86_64                                                                  3.18.2-1.fc23                                          @updates        
gnome-themes-standard.x86_64                                                           3.18.0-1.fc23                                          @koji-override-0
gnome-tweak-tool.noarch                                                                3.18.1-1.fc23                                          @updates        
gnome-user-share.x86_64                                                                3.18.0-1.fc23                                          @koji-override-0
gnome-vfs2.x86_64                                                                      2.24.4-19.fc23                                         @fedora         
gnome-vfs2-common.noarch                                                               2.24.4-19.fc23                                         @fedora         

xorg-x11-drv-intel.x86_64                                          2.99.917-19.20151206.fc23                                           @System                

How reproducible:

Steps to Reproduce:
1. Move cursor to top bar or popup desktop menu, or Activities

Actual results:
Mouse cursor is invisible.

Additional info:
Cursor become visible above any non-gnome-shell window. In Nautilus and Settings works very well, title bar works very well, but menu on it hides cursor.
Comment 1 olegon.ru 2016-03-08 23:07:13 EST
It's happen after last gnome-shell update yesterday.
Desktop is unoperable by mouse, I can run applications only by keyboard :(
Comment 2 olegon.ru 2016-03-09 12:05 EST
Created attachment 1134580 [details]
Video showing the problem
Comment 3 Uwe Köcher 2016-03-10 03:34:05 EST
I can confirm the issue.
Comment 4 Uwe Köcher 2016-03-10 04:06:07 EST
So, after downgrading several packages, I found that the defective update is for me the "mutter" package.

The original action of dnf was:

Upgraded mutter-3.18.2-1.fc23.x86_64                                    @updates
    Upgrade         3.18.3-1.fc23.x86_64                                    @updates

After downgrading (dnf downgrade mutter) to mutter-3.18.1-4.fc23.x86_64 everything looks normal (mouse pointer is visible on gnome login shell as well after login on desktop menus).
Comment 5 Ray Strode [halfline] 2016-03-10 10:52:57 EST
*** Bug 1316250 has been marked as a duplicate of this bug. ***
Comment 6 Ray Strode [halfline] 2016-03-10 10:53:57 EST
should be fixed now upstream, I think.

Note You need to log in before you can comment on or make changes to this bug.