Bug 1316078 - Document why rh-mongodb32-runtime depends on rh-java-common packages
Document why rh-mongodb32-runtime depends on rh-java-common packages
Status: CLOSED NOTABUG
Product: Red Hat Software Collections
Classification: Red Hat
Component: doc-Release_Notes (Show other bugs)
rh-mongodb32
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 2.2
Assigned To: Lenka Špačková
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-09 06:31 EST by Honza Horak
Modified: 2016-05-04 10:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-04 10:36:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Honza Horak 2016-03-09 06:31:00 EST
Description of problem:
rh-mongodb32-runtime depends on rh-java-common packages, I think it is not necessary and the dependencies should be somewhere else, -build subpackage? maybe even mongo-java-driver if it is needed.

Version-Release number of selected component (if applicable):
rh-mongodb32-2.2-7.el7
Comment 1 Marek Skalický 2016-03-14 09:32:20 EDT
rh-mongodb32-runtime depends on rh-java-common to be able to enable scl_java_common SCL by enabling rh-mongodb32 SCL - "scl enable rh-mongodb32"

This is a resolution of bug #1129287 from mongodb24 SCL. To be able to do "scl enable rh-mongodb32 -- build-jar-repository /tmp mongo"

Or shouldn't this be supported?
Comment 2 Honza Horak 2016-03-14 12:33:49 EDT
Oh, I haven't realized that, thank you for explaining. Then I think we should just add a comment into the SPEC file so we are clear about why it is done this way.
Comment 5 Marek Skalický 2016-03-17 06:46:48 EDT
This fix (dependency) is from mongodb24 era.

Should "If mongodb24 is made to depend on it too then just installing rh-common-java-javapackages-tools will "fix" build-jar-repository and other related tools. If collections want to have the feature of workning build-jar-repository (et al.) then they can add dependency on rh-common-java-javapackages-tools." (bug 1129287, comment 18) be supported also for rh-mongodb32?

Or is updated  workaround "scl enable maven30 mongodb24 -- build-jar-repository /tmp mongo" (bug 1129287, comment 17) enough for rh-mongodb32?

What "java functions and tools" should be enabled/functional only by enabling rh-mongodb32 collection?
Comment 6 Marek Skalický 2016-03-17 06:48:57 EDT
Mikolaj, what is a current status of build-jar-repository please? Should this collection still depends on rh-java-common-javapackages-tools?
Comment 7 Mikolaj Izdebski 2016-03-17 06:59:21 EDT
By design, any SCL must be enabled prior to using it, build-jar-repository and other related tools will only look for JARs from enabled collections. If you want out-of-the-box support for build-jar-repository in mongodb24 after installing (and enabling) it then dependency or rh-java-common-runtime is necessary and it's not planned to be changed.
Comment 8 Lenka Špačková 2016-05-04 10:36:23 EDT
The dependency is documented generally in the Release Notes, no details are relevant for customers.

Note You need to log in before you can comment on or make changes to this bug.