Bug 131608 - udev is not started (fix included)
udev is not started (fix included)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-02 13:36 EDT by Ralf Ertzinger
Modified: 2014-03-16 22:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-23 11:36:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Ertzinger 2004-09-02 13:36:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809

Description of problem:
udev is not being started by rc.sysinit due to a change in udev,
leading to all kinds of mysterious failures while booting.

In /etc/rc.sysinit, the line stating

if [ "$USE_UDEV" = "yes" -a "$UDEV_RAMFS" = "yes" ]; then

has to be changed to

if [ "$USE_UDEV" = "yes" -a "$UDEV_TMPFS" = "yes" ]; then

to keep track with udev.

Version-Release number of selected component (if applicable):
initscripts-7.74-1

How reproducible:
Always

Steps to Reproduce:
1.boot
2.
3.
    

Actual Results:  udev is not started

Expected Results:  udev must start and fix device permissions

Additional info:
Comment 1 Bill Nottingham 2004-09-02 15:02:56 EDT
fixed in 7.76 or so.
Comment 2 Harald Hoyer 2004-09-23 06:34:34 EDT
Ok, new changes.
Bill, please change the rc.sysinit udev part to this:

[ -x /sbin/start_udev ] && /sbin/start_udev

no need to source udev.conf, just call it.
The second start_udev, after remount rw should be removed also.
Comment 3 Bill Nottingham 2004-09-23 11:36:26 EDT
Already done in current builds.

Note You need to log in before you can comment on or make changes to this bug.