Bug 1316139 - "Unregister System" link should be disabled when no systems selected
"Unregister System" link should be disabled when no systems selected
Status: CLOSED WONTFIX
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Red Hat Access (Show other bugs)
5.5.0
Unspecified Unspecified
low Severity low
: GA
: cfme-future
Assigned To: Lindani Phiri
Satyajit Bulage
ui:access
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-09 09:05 EST by Vadim Rutkovsky
Modified: 2017-08-21 09:10 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (33.22 KB, image/png)
2016-03-09 09:05 EST, Vadim Rutkovsky
no flags Details

  None (edit)
Description Vadim Rutkovsky 2016-03-09 09:05:11 EST
Created attachment 1134534 [details]
Screenshot

Description of problem:
User can unselect all systems on Red Hat Insights / Systems page and a warning dialog with weird text "This will unregister the 0 selected systems" 

Version-Release number of selected component (if applicable):
5.5.2.4

How reproducible:
Always

Steps to Reproduce:
1. Subscribe an appliance and an instance
2. Open Red Hat Insights / Systems
3. Check "Unregister Systems" link state

Actual results:
The link is displayed and enabled - "Are you sure?" dialog is displayed (see attachment)

Expected results:
The link should either be disabled or hidden

Additional info:
Comment 2 Dave Johnson 2016-09-27 17:07:51 EDT
Satyajit, please review these and potentially redirect to Niyaz as appropriate.
Comment 3 Ian Page Hands 2017-07-20 09:19:06 EDT
Lindani, this is fixed in the upstream insights-frontend.
Comment 4 Chris Pelland 2017-08-21 09:08:30 EDT
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.
Comment 5 Chris Pelland 2017-08-21 09:10:33 EDT
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.

Note You need to log in before you can comment on or make changes to this bug.