Bug 1316149 - /etc/NetworkManager/dispatcher.d/50-ddclient looks for /var/lock/subsys/ddclient
/etc/NetworkManager/dispatcher.d/50-ddclient looks for /var/lock/subsys/ddclient
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ddclient (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Scott Talbert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-09 09:21 EST by dac.override
Modified: 2016-04-18 19:53 EDT (History)
2 users (show)

See Also:
Fixed In Version: ddclient-3.8.3-1.fc24 ddclient-3.8.3-1.fc23 ddclient-3.8.3-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-06 10:08:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dac.override 2016-03-09 09:21:19 EST
Description of problem:

/etc/NetworkManager/dispatcher.d/50-ddclient looks for /var/lock/subsys/ddclient, but that files seems to not be maintained by ddclient.

Version-Release number of selected component (if applicable):
ddclient-3.8.2-2.fc21.noarch


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Also in /usr/lib/systemd/system/ddclient.service:

ExecStartPre=/bin/touch /var/cache/ddclient/ddclient.cache

why is that needed? The file is installed by the RPM package
Comment 1 Fedora Admin XMLRPC Client 2016-03-26 23:36:17 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Fedora Admin XMLRPC Client 2016-03-27 16:11:12 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Scott Talbert 2016-03-29 00:26:00 EDT
(In reply to dac.override from comment #0)
> Also in /usr/lib/systemd/system/ddclient.service:
> 
> ExecStartPre=/bin/touch /var/cache/ddclient/ddclient.cache
> 
> why is that needed? The file is installed by the RPM package

Actually, it looks like that file isn't installed by the RPM - it's a ghost file.  It shows up in "rpm -ql" but isn't actually installed by RPM.  It will be deleted, however, if the RPM is removed.
Comment 4 dac.override 2016-03-29 03:15:54 EDT
o, ok. thanks!
Comment 5 dac.override 2016-03-29 03:38:18 EDT
ideally though it would be nice to have the ddclient script itself maintain that file.
Comment 6 Fedora Update System 2016-03-31 23:00:35 EDT
ddclient-3.8.3-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-607ade496c
Comment 7 Fedora Update System 2016-04-02 00:27:01 EDT
ddclient-3.8.3-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-8d37aa5ac1
Comment 8 Fedora Update System 2016-04-02 01:25:19 EDT
ddclient-3.8.3-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-607ade496c
Comment 9 Fedora Update System 2016-04-02 17:19:46 EDT
ddclient-3.8.3-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-8d37aa5ac1
Comment 10 Fedora Update System 2016-04-02 20:13:44 EDT
ddclient-3.8.3-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-0b30d61ea4
Comment 11 Fedora Update System 2016-04-03 18:21:06 EDT
ddclient-3.8.3-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-0b30d61ea4
Comment 12 Fedora Update System 2016-04-06 10:08:10 EDT
ddclient-3.8.3-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2016-04-13 03:23:47 EDT
ddclient-3.8.3-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2016-04-18 19:53:38 EDT
ddclient-3.8.3-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.