Bug 13162 - Complete lockup after shutting notebook lid under X
Summary: Complete lockup after shutting notebook lid under X
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-28 13:08 UTC by Bas Mevissen
Modified: 2008-08-01 16:22 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-28 13:08:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bas Mevissen 2000-06-28 13:08:13 UTC
My Dell Inspiron 5000 600VT locks up completely at resume after a suspend 
by shutting the lid of the notebook under X.

The screen comes up again and I can move the mouse for a while. Then it 
locks up completely and I have to shut it down with the power button.

I also got some troubles with the 2.2.14-12 kernel, but there was an APM 
bug in the kernel that got fixed in 2.2.15. With the 2.2.14 kernel, I also 
got HDA interrupt timeout warnings and could not access the disk after a 
resume.

Currently, I do not have a PCMCIA card in one of the slots or other 
extensions. My notebook has a 600MHz PIII speedstep with 128Mb of memory. 
In the BIOS, I've set the hibernate option to "RAM".

BTW. Is there a tool to stop the notebook from suspending if I close the 
lid? Under Win2000 it is possible.

Thanks,

Bas.

Comment 1 Bas Mevissen 2000-07-10 11:27:18 UTC
According to XFree86 Mach64 maintainer (Marc Aurele La France), this problem is known and fixed in XFree86-4.0.1. There is no backport to be 
expected soon. So this bug may live forever in XFree86-3.3.6 and lower.

Fix probably is to upgrade to XFree 4.0.1. I did check the code (looks properly fixed, not just a hack), but did not test it yet. Will try with RawHide version 
of package or from XFree86 official source if possible.

I think the best thing to do now is to leave this as is, because a back-port is a waste of time. Maybe this can be addes to the HCL.

Comment 2 Bas Mevissen 2000-07-10 11:28:22 UTC
According to XFree86 Mach64 maintainer (Marc Aurele La France), this problem is known and fixed in XFree86-4.0.1. There is no backport to be 
expected soon. So this bug may live forever in XFree86-3.3.6 and lower.

Fix probably is to upgrade to XFree 4.0.1. I did check the code (looks properly fixed, not just a hack), but did not test it yet. Will try with RawHide 
version 
of package or from XFree86 official source if possible.

I think the best thing to do now is to leave this as is, because a back-port is a waste of time. Maybe this can be added to the HCL.


Note You need to log in before you can comment on or make changes to this bug.