This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1316424 - Regression local 127.0.0.1 node not registered by default
Regression local 127.0.0.1 node not registered by default
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kubernetes (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Chaloupka
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-10 03:29 EST by Stef Walter
Modified: 2016-04-06 10:08 EDT (History)
7 users (show)

See Also:
Fixed In Version: kubernetes-1.2.0-0.15.alpha6.gitf0cd09a.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-06 10:08:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stef Walter 2016-03-10 03:29:08 EST
Description of problem:

The local 127.0.0.1 kubernetes node should register itself in the default install. In the fedora-24 build it no longer does:

Version-Release number of selected component (if applicable):

kubernetes-1.2.0-0.14.alpha6.gitf0cd09a.fc24.x86_64

How reproducible:

Every time


Steps to Reproduce:
1. systemctl start etcd kube-apiserver kube-controller-manager kube-scheduler docker kube-proxy kubelet
2. kubectl get nodes # wait or repeat as needed

Actual results:

No output.

Expected results:

NAME        LABELS                             STATUS
127.0.0.1   kubernetes.io/hostname=127.0.0.1   Ready

Additional info:

This works on fedora-23 with the following kubernetes RPM: kubernetes-1.1.0-0.17.git388061f.fc23.x86_64. In addition the following RPM from fedora-23 updates-testing 1.2.0-0.15.alpha6.gitf0cd09a.fc23
Comment 1 Jan Chaloupka 2016-03-10 04:08:17 EST
Stef, can you checkout kubernetes-1.2.0-0.15.alpha6.gitf0cd09a.fc23? Running rpms from the build show the expected result.

[1] http://koji.fedoraproject.org/koji/buildinfo?buildID=743082
Comment 2 Stef Walter 2016-03-10 04:20:43 EST
This problem is happening on Fedora 24. Do you have a Fedora 24 build of that RPM?
Comment 4 Stef Walter 2016-03-10 04:45:53 EST
The issue remains with that build:

# rpm -q kubernetes
kubernetes-1.2.0-0.14.alpha6.gitf0cd09a.fc24.x86_64
# kubectl get nodes

No output above. All services are running:

# kubectl version
Client Version: version.Info{Major:"1", Minor:"2", GitVersion:"v1.2.0", GitCommit:"cffae0523cfa80ddf917aba69f08508b91f603d5", GitTreeState:"clean"}
Server Version: version.Info{Major:"1", Minor:"2", GitVersion:"v1.2.0", GitCommit:"cffae0523cfa80ddf917aba69f08508b91f603d5", GitTreeState:"clean"}
# systemctl status kube-*
● kube-proxy.service - Kubernetes Kube-Proxy Server
   Loaded: loaded (/usr/lib/systemd/system/kube-proxy.service; disabled; vendor 
   Active: active (running) since Thu 2016-03-10 04:43:18 EST; 1min 28s ago
     Docs: https://github.com/GoogleCloudPlatform/kubernetes
 Main PID: 1239 (kube-proxy)
    Tasks: 7 (limit: 512)
   CGroup: /system.slice/kube-proxy.service
           └─1239 /usr/bin/kube-proxy --logtostderr=true --v=0 --master=http://1

Mar 10 04:43:20 localhost.localdomain kube-proxy[1239]: Try `iptables -h' or 'ip
Mar 10 04:43:20 localhost.localdomain kube-proxy[1239]: E0310 04:43:20.006343   
Mar 10 04:43:20 localhost.localdomain kube-proxy[1239]: E0310 04:43:20.007063   
Mar 10 04:43:20 localhost.localdomain kube-proxy[1239]: E0310 04:43:20.008956   
Mar 10 04:43:20 localhost.localdomain kube-proxy[1239]: E0310 04:43:20.010194   
Mar 10 04:43:20 localhost.localdomain kube-proxy[1239]: I0310 04:43:20.040594   
Mar 10 04:43:20 localhost.localdomain kube-proxy[1239]: I0310 04:43:20.040685   
Mar 10 04:43:20 localhost.localdomain kube-proxy[1239]: I0310 04:43:20.040858   
Mar 10 04:43:20 localhost.localdomain kube-proxy[1239]: E0310 04:43:20.063331   
Mar 10 04:43:21 localhost.localdomain kube-proxy[1239]: E0310 04:43:21.276617   

● kube-scheduler.service - Kubernetes Scheduler Plugin
   Loaded: loaded (/usr/lib/systemd/system/kube-scheduler.service; disabled; ven
   Active: active (running) since Thu 2016-03-10 04:43:18 EST; 1min 28s ago
     Docs: https://github.com/GoogleCloudPlatform/kubernetes
 Main PID: 1244 (kube-scheduler)
    Tasks: 5 (limit: 512)
   CGroup: /system.slice/kube-scheduler.service
           └─1244 /usr/bin/kube-scheduler --logtostderr=true --v=0 --master=http

Mar 10 04:43:18 localhost.localdomain systemd[1]: Started Kubernetes Scheduler P
Mar 10 04:43:19 localhost.localdomain kube-scheduler[1244]: W0310 04:43:19.86344
Mar 10 04:43:19 localhost.localdomain kube-scheduler[1244]: W0310 04:43:19.86352

● kube-controller-manager.service - Kubernetes Controller Manager
   Loaded: loaded (/usr/lib/systemd/system/kube-controller-manager.service; disa
   Active: active (running) since Thu 2016-03-10 04:43:18 EST; 1min 28s ago
     Docs: https://github.com/GoogleCloudPlatform/kubernetes
 Main PID: 1249 (kube-controller)
    Tasks: 6 (limit: 512)
   CGroup: /system.slice/kube-controller-manager.service
           └─1249 /usr/bin/kube-controller-manager --logtostderr=true --v=0 --ma

Mar 10 04:43:20 localhost.localdomain kube-controller-manager[1249]: E0310 04:43
Mar 10 04:43:21 localhost.localdomain kube-controller-manager[1249]: W0310 04:43
Mar 10 04:43:21 localhost.localdomain kube-controller-manager[1249]: W0310 04:43
Mar 10 04:43:21 localhost.localdomain kube-controller-manager[1249]: W0310 04:43
Mar 10 04:43:21 localhost.localdomain kube-controller-manager[1249]: W0310 04:43
Mar 10 04:43:21 localhost.localdomain kube-controller-manager[1249]: W0310 04:43
Mar 10 04:43:21 localhost.localdomain kube-controller-manager[1249]: W0310 04:43
Mar 10 04:43:21 localhost.localdomain kube-controller-manager[1249]: W0310 04:43
Mar 10 04:43:21 localhost.localdomain kube-controller-manager[1249]: W0310 04:43
Mar 10 04:43:21 localhost.localdomain kube-controller-manager[1249]: W0310 04:43

● kube-apiserver.service - Kubernetes API Server
   Loaded: loaded (/usr/lib/systemd/system/kube-apiserver.service; disabled; ven
   Active: active (running) since Thu 2016-03-10 04:43:21 EST; 1min 25s ago
     Docs: https://github.com/GoogleCloudPlatform/kubernetes
 Main PID: 1313 (kube-apiserver)
    Tasks: 6 (limit: 512)
   CGroup: /system.slice/kube-apiserver.service
           └─1313 /usr/bin/kube-apiserver --logtostderr=true --v=0 --etcd-server

Mar 10 04:43:20 localhost.localdomain kube-apiserver[1313]: I0310 04:43:20.29312
Mar 10 04:43:20 localhost.localdomain kube-apiserver[1313]: I0310 04:43:20.29433
Mar 10 04:43:20 localhost.localdomain kube-apiserver[1313]: I0310 04:43:20.29920
Mar 10 04:43:20 localhost.localdomain kube-apiserver[1313]: [restful] 2016/03/10
Mar 10 04:43:20 localhost.localdomain kube-apiserver[1313]: [restful] 2016/03/10
Mar 10 04:43:20 localhost.localdomain kube-apiserver[1313]: W0310 04:43:20.63368
Mar 10 04:43:20 localhost.localdomain kube-apiserver[1313]: I0310 04:43:20.65604
Mar 10 04:43:21 localhost.localdomain kube-apiserver[1313]: I0310 04:43:21.41848
Mar 10 04:43:21 localhost.localdomain kube-apiserver[1313]: I0310 04:43:21.41872
Mar 10 04:43:21 localhost.localdomain systemd[1]: Started Kubernetes API Server.
Comment 5 Stef Walter 2016-03-10 04:56:18 EST
I spoke too soon, and didn't get the right build. This build seems to work:

# kubectl get nodes
NAME        LABELS                             STATUS    AGE
127.0.0.1   kubernetes.io/hostname=127.0.0.1   Ready     3s
# rpm -q kubernetes
kubernetes-1.2.0-0.15.alpha6.gitf0cd09a.fc23.x86_64
Comment 6 Jan Chaloupka 2016-03-10 04:58:06 EST
Thanks for verifying.
Comment 7 Stef Walter 2016-03-10 06:02:36 EST
Worth noting that this isn't fixed yet in Fedora 24. Although the above build exists. Running 'yum update' on fedora-24 doesn't fix the issue. I think a bodhi update is necessary.
Comment 8 Fedora Update System 2016-03-10 06:09:53 EST
kubernetes-1.2.0-0.15.alpha6.gitf0cd09a.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-49a2ed017f
Comment 9 Jan Chaloupka 2016-03-10 06:10:24 EST
Interesting, though it will take more time to enable updates for f24. Updated.
Comment 10 Fedora Update System 2016-03-11 14:27:45 EST
kubernetes-1.2.0-0.15.alpha6.gitf0cd09a.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-49a2ed017f
Comment 11 Fedora Update System 2016-04-06 10:08:51 EDT
kubernetes-1.2.0-0.15.alpha6.gitf0cd09a.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.