Bug 1316457 - [RDO Mitaka3 test day] Distributed -IPv6-Deployment- Sanity
[RDO Mitaka3 test day] Distributed -IPv6-Deployment- Sanity
Status: CLOSED NOTABUG
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
trunk
Unspecified Unspecified
unspecified Severity unspecified
: ---
: Kilo
Assigned To: Martin Magr
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-10 05:03 EST by Martin Magr
Modified: 2016-04-18 03:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-10 05:50:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Magr 2016-03-10 05:03:41 EST
Description of problem:
Distributed IPv6 installation via packstack fails with unknown 'iptables-ipv6' package:

Copying Puppet modules and manifests                 [ DONE ]
Applying fd00::1b16_prescript.pp
Applying fd00::1b17_prescript.pp
Applying fd00::1b15_prescript.pp
fd00::1b15_prescript.pp:                          [ ERROR ]        
Applying Puppet manifests                         [ ERROR ]

ERROR : Error appeared during Puppet run: fd00::1b15_prescript.pp
Error: Execution of '/usr/bin/yum -d 0 -e 0 -y list iptables-ipv6' returned 1: Error: No matching Packages to list
You will find full trace in log /var/tmp/packstack/20160310-105808-57E5qE/manifests/fd00::1b15_prescript.pp.log


Version-Release number of selected component (if applicable):
[root@test-controller ~]# rpm -qa openstack*
openstack-puppet-modules-8.0.0a0-0.20160304203011.7dc7e93.el7.centos.noarch
openstack-packstack-puppet-7.0.0-0.12.dev1699.g8f54936.el7.noarch
openstack-packstack-7.0.0-0.12.dev1699.g8f54936.el7.noarch


Additional info:
[root@test-controller ~]# cat /var/tmp/packstack/20160310-105808-57E5qE/manifests/fd00::1b15_prescript.pp.log
Notice: Compiled catalog for test-compute.internal in environment production in 0.23 seconds
Warning: The package type's allow_virtual parameter will be changing its default value from false to true in a future release. If you do not want to allow virtual packages, please explicitly set allow_virtual to false.
   (at /usr/share/ruby/vendor_ruby/puppet/type.rb:816:in `set_default')
Error: Execution of '/usr/bin/yum -d 0 -e 0 -y list iptables-ipv6' returned 1: Error: No matching Packages to list
Error: /Stage[main]/Firewall::Linux::Redhat/Package[iptables-ipv6]/ensure: change from absent to present failed: Execution of '/usr/bin/yum -d 0 -e 0 -y list iptables-ipv6' returned 1: Error: No matching Packages to list
Notice: /Stage[main]/Firewall::Linux::Redhat/Service[iptables]: Dependency Package[iptables-ipv6] has failures: true
Warning: /Stage[main]/Firewall::Linux::Redhat/Service[iptables]: Skipping because of failed dependencies
Notice: Finished catalog run in 0.51 seconds
[root@test-controller ~]#
Comment 1 Martin Magr 2016-03-10 05:50:14 EST
This one was caused by my broken CentOS7 installation, so not a bug.

Note You need to log in before you can comment on or make changes to this bug.